package/libev: bump version to 4.22
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 29 Jan 2016 21:53:02 +0000 (22:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 30 Jan 2016 07:34:05 +0000 (08:34 +0100)
This patch also fixes the broken download of version 4.19 because
upstream move the archive file to Attic/

Removed patch after upstream applied a similar fix:
http://cvs.schmorp.de/libev/ev.c?r1=1.476&r2=1.477

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libev/0001-fix-sparcv8-condition.patch [deleted file]
package/libev/libev.hash
package/libev/libev.mk

diff --git a/package/libev/0001-fix-sparcv8-condition.patch b/package/libev/0001-fix-sparcv8-condition.patch
deleted file mode 100644 (file)
index d411f83..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-Fix SPARCv8 condition
-
-The define provided by the compiler on SPARCv8 is __sparc_v8__ and not
-__sparcv8. From a SPARCv8 gcc:
-
-$ sparc-linux-gcc --version
-sparc-linux-gcc (Buildroot 2015.08-git-00497-ge110081) 4.9.3
-[...]
-$ sparc-linux-gcc -dM -E - < /dev/null | grep sparc
-#define sparc 1
-#define __sparc__ 1
-#define __sparc 1
-#define __sparc_v8__ 1
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/ev.c
-===================================================================
---- a/ev.c
-+++ b/ev.c
-@@ -649,7 +649,7 @@
-       #define ECB_MEMORY_FENCE         __asm__ __volatile__ ("dmb"      : : : "memory")
-     #elif __aarch64__
-       #define ECB_MEMORY_FENCE         __asm__ __volatile__ ("dmb ish"  : : : "memory")
--    #elif (__sparc || __sparc__) && !__sparcv8
-+    #elif (__sparc || __sparc__) && !__sparc_v8__
-       #define ECB_MEMORY_FENCE         __asm__ __volatile__ ("membar #LoadStore | #LoadLoad | #StoreStore | #StoreLoad" : : : "memory")
-       #define ECB_MEMORY_FENCE_ACQUIRE __asm__ __volatile__ ("membar #LoadStore | #LoadLoad"                            : : : "memory")
-       #define ECB_MEMORY_FENCE_RELEASE __asm__ __volatile__ ("membar #LoadStore             | #StoreStore")
index 22524836f8e8d9ff518b0eaae4fe30399e1a065b..7f029df7fa21ec6c381a80db7603f8f24f85717b 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 88fc5f89ca96ceca14c16c10e7be3e921dae65e84932d680c2fd6a40173edccb        libev-4.19.tar.gz
+sha256 736079e8ac543c74d59af73f9c52737b3bfec9601f020bf25a87a4f4d0f01bd6        libev-4.22.tar.gz
index cde2ee03863558c8c69454b10deb19670ace72fd..02bc72cba2c3056782d913f4349355205bedec08 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBEV_VERSION = 4.19
+LIBEV_VERSION = 4.22
 LIBEV_SITE = http://dist.schmorp.de/libev
 LIBEV_INSTALL_STAGING = YES
 LIBEV_LICENSE = BSD-2c or GPLv2+