nginx-upload: new package
authorBimal Jacob <Bimal.Jacob@rockwellcollins.com>
Fri, 15 Jul 2016 03:10:17 +0000 (22:10 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Jul 2016 20:22:39 +0000 (22:22 +0200)
A module for nginx web server for handling file uploads using
multipart/form-data encoding (RFC 1867).

Signed-off-by: Bimal Jacob <bimal.jacob@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
[Thomas:
 - rename from nginx-upload-module to nginx-upload. Indeed, we don't
   want all nginx modules to be suffixed with "-module"
 - include the module Config.in file directly from package/Config.in,
   like we do for Python, Perl, Lua or TCL modules.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/nginx-upload/Config.in [new file with mode: 0644]
package/nginx-upload/nginx-upload.hash [new file with mode: 0644]
package/nginx-upload/nginx-upload.mk [new file with mode: 0644]
package/nginx/nginx.mk

index da7b8555e3df17a56a71cf38415120c4260f5a98..7756a4c603938d7d8b09eea1f5f248b0a1eead0a 100644 (file)
@@ -1499,6 +1499,11 @@ menu "Networking applications"
        source "package/nfacct/Config.in"
        source "package/nftables/Config.in"
        source "package/nginx/Config.in"
+if BR2_PACKAGE_NGINX
+menu "External nginx modules"
+       source "package/nginx-upload/Config.in"
+endmenu
+endif
        source "package/ngircd/Config.in"
        source "package/ngrep/Config.in"
        source "package/nload/Config.in"
diff --git a/package/nginx-upload/Config.in b/package/nginx-upload/Config.in
new file mode 100644 (file)
index 0000000..b4ee71c
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_NGINX_UPLOAD
+       bool "nginx-upload"
+       select BR2_PACKAGE_OPENSSL
+       help
+         A module for nginx web server for handling file uploads
+         using multipart/form-data encoding (RFC 1867).
+
+         https://github.com/vkholodkov/nginx-upload-module
diff --git a/package/nginx-upload/nginx-upload.hash b/package/nginx-upload/nginx-upload.hash
new file mode 100644 (file)
index 0000000..4fc4347
--- /dev/null
@@ -0,0 +1,2 @@
+#Locally Computed:
+sha256 8cd1d9d968ffba807de2e546ea9cad5e1ae294ec60b4927b2d60a98bdb4a1144  nginx-upload-aba1e3f34c754551f4f49e572bc86863d535609d.tar.gz
diff --git a/package/nginx-upload/nginx-upload.mk b/package/nginx-upload/nginx-upload.mk
new file mode 100644 (file)
index 0000000..6f94d35
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# nginx-upload
+#
+################################################################################
+
+NGINX_UPLOAD_VERSION = aba1e3f34c754551f4f49e572bc86863d535609d
+NGINX_UPLOAD_SITE = $(call github,vkholodkov,nginx-upload-module,$(NGINX_UPLOAD_VERSION))
+NGINX_UPLOAD_LICENSE = BSD-3c
+NGINX_UPLOAD_LICENSE_FILES = LICENCE
+NGINX_UPLOAD_DEPENDENCIES = openssl
+
+$(eval $(generic-package))
index 5eb5488bd9dedc8cf14efd8be867179084107c86..018d0f884fb001a08eabb894c1631d82ea1b7307 100644 (file)
@@ -234,6 +234,12 @@ NGINX_CONF_OPTS += \
 
 endif # BR2_PACKAGE_NGINX_STREAM
 
+# external modules
+ifeq ($(BR2_PACKAGE_NGINX_UPLOAD),y)
+NGINX_CONF_OPTS += $(addprefix --add-module=,$(NGINX_UPLOAD_DIR))
+NGINX_DEPENDENCIES += nginx-upload
+endif
+
 # Debug logging
 NGINX_CONF_OPTS += $(if $(BR2_PACKAGE_NGINX_DEBUG),--with-debug)