manual: Add note about uses of github helper
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Wed, 15 Oct 2014 12:24:20 +0000 (14:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 16 Oct 2014 17:05:40 +0000 (19:05 +0200)
Add a little comment regarding the uses of the github helper for the releases.

[Arnout: extend the comment a little]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Samuel Martin <s.martin49@gmail.com>
Acked-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/adding-packages-tips.txt

index 0d4fcb062756b84cab9fc6a76c49609673ed386e..0c6018a6a01ba96248a7701cb98478e44cf174ed 100644 (file)
@@ -52,3 +52,20 @@ FOO_SITE = $(call github,<user>,<package>,$(FOO_VERSION))
   Buildroot (e.g.: +foo-f6fb6654af62045239caed5950bc6c7971965e60.tar.gz+),
   so it is not necessary to specify it in the +.mk+ file.
 - When using a commit ID as version, you should use the full 40 hex characters.
+
+If the package you wish to add does have a release section on GitHub, the
+maintainer may have uploaded a release tarball, or the release may just point
+to the automatically generated tarball from the git tag. If there is a
+release tarball uploaded by the maintainer, we prefer to use that since it
+may be slightly different (e.g. it contains a configure script so we don't
+need to do AUTORECONF).
+
+You can see on the release page if it's an uploaded tarball or a git tag:
+- If there is a green download button, like
+  https://github.com/zedshaw/mongrel2/releases/tag/v1.9.1[mongrel2], then it
+  was uploaded by the maintainer and you should use the link of that button to
+  specify +FOO_SITE+.
+- If there is grey download button, like
+  https://github.com/xbmc/xbmc/releases/tag/13.2-Gotham[xbmc], then it's an
+  automatically generated tarball and you should use the 'github' helper
+  function.