gpsd: correct explicit nmea 0183 support flag
authorJames Knight <james.knight@rockwellcollins.com>
Thu, 5 Nov 2015 18:41:52 +0000 (13:41 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 Nov 2015 21:00:20 +0000 (22:00 +0100)
The following handles the GPSd SCons change for the explicit
configuration of the NMEA 0183 protocol. The protocol configuration
change was introduced in 3.12. Developer's who transitioned to
Buildroot's GPSd 3.15 had NMEA 0183 implicitly enabled by default. This
change allows NMEA 0183 to be explicitly disabled again.

See:
 http://git.savannah.gnu.org/cgit/gpsd.git/commit/SConstruct?id=8f20d7b2d1ece8f3205ca038726c77daa5234c0c

Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gpsd/gpsd.mk

index 2199e313e10a5b9980629c4e6b4dfc51b0eb1726..577b43cfcc1bb008920dcdac7d49a3d03232a3db 100644 (file)
@@ -102,7 +102,7 @@ ifneq ($(BR2_PACKAGE_GPSD_MTK3301),y)
 GPSD_SCONS_OPTS += mtk3301=no
 endif
 ifneq ($(BR2_PACKAGE_GPSD_NMEA),y)
-GPSD_SCONS_OPTS += nmea=no
+GPSD_SCONS_OPTS += nmea0183=no
 endif
 ifneq ($(BR2_PACKAGE_GPSD_NTRIP),y)
 GPSD_SCONS_OPTS += ntrip=no