iperf: override bool detection
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 May 2010 21:50:11 +0000 (23:50 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 May 2010 21:50:11 +0000 (23:50 +0200)
The configure script contains a buggy test for the bool datatype and
it's size. This is normally not a big deal as the result isn't used
for anything, but when BR2_CONFIG_CACHE (default) is used, the
wrong ac_cv_type_bool result is stored in the cache, and other packages
like libcurl DO need the bool type, so that breaks the build.

Fix it by presetting those tests to sane values.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/iperf/iperf.mk

diff --git a/CHANGES b/CHANGES
index 6dcf97c57ddc975a3e157bfbd94db27cdc2f5145..af7318745b37a66f34d54a4f4474237aa9cd9af7 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,7 +5,7 @@
        Updated/fixed packages: aumix, atk, avahi, bmon, busybox, cairo,
        cdrkit, dbus-glib, dbus-python, docker, enchant, fltk, gamin,
        gettext, gmpc, gob2, grep, gstreamer, gst-plugins-bad,
-       gst-plugins-base, gvfs, hal, iconv, icu, libcgicc, libdvdnav,
+       gst-plugins-base, gvfs, hal, iconv, icu, iperf, libcgicc, libdvdnav,
        libdvdread, libglade, libglib2, libgtk2, libidn, libmms,
        libmpd, libpcap, libsoup, lmbench, lsof, ltrace, lvm2, make,
        metacity, mtd-utils, mutt, nbd, netsnmp, ntfsprogs, ntp, olsr,
index 10e5a37838461e88d45cf98002511432353a23b6..3f8e3fc8c185e2613b69256f8b4e5fb20707c3e8 100644 (file)
@@ -14,7 +14,9 @@ IPERF_INSTALL_STAGING = NO
 IPERF_INSTALL_TARGET = YES
 
 IPERF_CONF_ENV = \
-       ac_cv_func_malloc_0_nonnull=yes
+       ac_cv_func_malloc_0_nonnull=yes \
+       ac_cv_type_bool=yes \
+       ac_cv_sizeof_bool=1
 
 IPERF_CONF_OPT = \
        --disable-dependency-tracking \