package/docker-engine: bump version to 20.10.6
authorMario Fink <mario.fink@record-evolution.de>
Mon, 19 Apr 2021 10:47:51 +0000 (12:47 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 2 May 2021 19:08:41 +0000 (21:08 +0200)
Fixes various networking issues:

- Fix a regression in docker 20.10, causing IPv6 addresses no longer to be
  bound by default when mapping ports moby/moby#42205

- Fix implicit IPv6 port-mappings not included in API response.  Before
  docker 20.10, published ports were accessible through both IPv4 and IPv6
  by default, but the API only included information about the IPv4 (0.0.0.0)
  mapping moby/moby#42205

- Fix a regression in docker 20.10, causing the docker-proxy to not be
  terminated in all cases moby/moby#42205

- Fix iptables forwarding rules not being cleaned up upon container removal
  moby/moby#42205

For more details, see the release notes:
https://docs.docker.com/engine/release-notes/#20106

Signed-off-by: Mario Fink <knif.oiram@gmail.com>
Tested-by: Christian Stewart <christian@paral.in>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/docker-engine/docker-engine.hash
package/docker-engine/docker-engine.mk

index 7e3ce6a5cf73319d0f692b340a0b4b908f53d9aa..6c55b9a9b9df15cfe0cff5952b426984c86d7991 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256  bcf651d75e5c80421e8cd3b0d47f3425e01047cf67aef0eda83b68776905a583  docker-engine-20.10.5.tar.gz
+sha256  fd7f5571b1f64f26b5ca520a3e1fefb33c190f3732b931051c23a76bdba5000e  docker-engine-20.10.6.tar.gz
 sha256  7c87873291f289713ac5df48b1f2010eb6963752bbd6b530416ab99fc37914a8  LICENSE
index 767818ebba77786c763be6d255fe6c0f374c76a3..10ecbf603a3a52c17704697ae25f1088adf12ab2 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-DOCKER_ENGINE_VERSION = 20.10.5
+DOCKER_ENGINE_VERSION = 20.10.6
 DOCKER_ENGINE_SITE = $(call github,moby,moby,v$(DOCKER_ENGINE_VERSION))
 
 DOCKER_ENGINE_LICENSE = Apache-2.0