leveldb: fix static build
authorBaruch Siach <baruch@tkos.co.il>
Thu, 8 Sep 2016 12:26:16 +0000 (15:26 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Sep 2016 20:36:09 +0000 (22:36 +0200)
Since version 1.19 Makefile variable names changed. Update the build command
accordingly.

While at it, remove variables that Makefile doesn't use anymore. This change
means that the static library is always build, even when BR2_SHARED_LIBS=y,
since the static library name is hard coded in leveldb Makefile.

Fixes:
http://autobuild.buildroot.net/results/00c/00c8c5a1d6001eaebfe2a9f848dd292c91bf6a79/

Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/leveldb/leveldb.mk

index 2ce3e4ace4ed100346bd3d3b93a309dd9a1c263a..ca2ed703a0bdc04c8c7e1c074e278f5601c8314e 100644 (file)
@@ -11,17 +11,9 @@ LEVELDB_LICENSE_FILES = LICENSE
 LEVELDB_INSTALL_STAGING = YES
 LEVELDB_DEPENDENCIES = snappy
 
-# We will pass optimisation level via CFLAGS so remove leveldb default
-LEVELDB_MAKE_ARGS += OPTIM=
-
-# Disable the static library for shared only build
-ifeq ($(BR2_SHARED_LIBS),y)
-LEVELDB_MAKE_ARGS += LIBRARY=
-endif
-
 # Disable the shared library for static only build
 ifeq ($(BR2_STATIC_LIBS),y)
-LEVELDB_MAKE_ARGS += SHARED=
+LEVELDB_MAKE_ARGS += SHARED_LIBS= SHARED_PROGRAMS=
 endif
 
 define LEVELDB_BUILD_CMDS