package/erlang-jose: new package
authorJohan Oudinet <johan.oudinet@gmail.com>
Mon, 6 Jan 2020 16:11:08 +0000 (17:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 6 Jan 2020 20:24:44 +0000 (21:24 +0100)
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/erlang-jose/Config.in [new file with mode: 0644]
package/erlang-jose/erlang-jose.hash [new file with mode: 0644]
package/erlang-jose/erlang-jose.mk [new file with mode: 0644]

index 590c54d06595154bb44089e89457cd3a880e654e..18adc166f7b72597e8947c8bcd1c4613eeb76fd8 100644 (file)
@@ -1259,6 +1259,7 @@ F:        package/erlang-base64url/
 F:     package/erlang-eimp/
 F:     package/erlang-goldrush/
 F:     package/erlang-jiffy/
+F:     package/erlang-jose/
 F:     package/erlang-lager/
 F:     package/erlang-p1-cache-tab/
 F:     package/erlang-p1-iconv/
index 0c4698f6015a55ef44715d5d76d3b3654405c839..52d556c5eedf3f05c72d84a03b98ba032208c024 100644 (file)
@@ -580,6 +580,7 @@ menu "Erlang libraries/modules"
        source "package/erlang-eimp/Config.in"
        source "package/erlang-goldrush/Config.in"
        source "package/erlang-jiffy/Config.in"
+       source "package/erlang-jose/Config.in"
        source "package/erlang-lager/Config.in"
        source "package/erlang-p1-cache-tab/Config.in"
        source "package/erlang-p1-iconv/Config.in"
diff --git a/package/erlang-jose/Config.in b/package/erlang-jose/Config.in
new file mode 100644 (file)
index 0000000..8101ff4
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_ERLANG_JOSE
+       bool "erlang-jose"
+       select BR2_PACKAGE_ERLANG_BASE64URL
+       help
+         JSON Object Signing and Encryption (JOSE) for Erlang and
+         Elixir.
+
+         https://github.com/potatosalad/erlang-jose
diff --git a/package/erlang-jose/erlang-jose.hash b/package/erlang-jose/erlang-jose.hash
new file mode 100644 (file)
index 0000000..71a1543
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 d55a9d3a1697833fed555a21f1aeb2727af88193995cb6ffa945d4b6749d0e8d erlang-jose-1.9.0.tar.gz
+sha256 6397e2bd9a35a64c1bb798b937071fbe49d90667f717e65c74a0d0fe93d5c1be LICENSE.md
diff --git a/package/erlang-jose/erlang-jose.mk b/package/erlang-jose/erlang-jose.mk
new file mode 100644 (file)
index 0000000..43ed22a
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# erlang-jose
+#
+################################################################################
+
+ERLANG_JOSE_VERSION = 1.9.0
+ERLANG_JOSE_SITE = $(call github,potatosalad,erlang-jose,$(ERLANG_JOSE_VERSION))
+ERLANG_JOSE_LICENSE = MIT
+ERLANG_JOSE_LICENSE_FILES = LICENSE.md
+ERLANG_JOSE_DEPENDENCIES = erlang-base64url
+
+$(eval $(rebar-package))