protobuf-c: Don't require protobuf on target.
authorStefan Sørensen <stefan.sorensen@spectralink.com>
Tue, 14 Jan 2014 08:21:36 +0000 (09:21 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 15 Jan 2014 21:18:08 +0000 (22:18 +0100)
protobuf-c only requires protobuf when building the protoc compiler,
hence protobuf can be dropped from the target dependencies.

Signed-off-by: Stefan Sørensen <stefan.sorensen@spectralink.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/protobuf-c/Config.in
package/protobuf-c/protobuf-c.mk

index 3baa05e8958f4ba4899cedb42415d07fd3534590..732befc9c0c44e12f7003a91867f8572c642d882 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_PROTOBUF_C
        bool "protobuf-c"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS # protobuf
-       select BR2_PACKAGE_PROTOBUF
        help
          Code generator and runtime libraries to use Protocol Buffers
          from pure C (not C++).
index 271f6d812be7b49d93214fd4fcbc4f583284b84a..42f592b38ecc4666fbdc9482bb83816cab58a796 100644 (file)
@@ -6,7 +6,7 @@
 
 PROTOBUF_C_VERSION = 0.15
 PROTOBUF_C_SITE = http://protobuf-c.googlecode.com/files
-PROTOBUF_C_DEPENDENCIES = protobuf host-protobuf-c
+PROTOBUF_C_DEPENDENCIES = host-protobuf-c
 HOST_PROTOBUF_C_DEPENDENCIES = host-protobuf
 PROTOBUF_C_MAKE = $(MAKE1)
 PROTOBUF_C_CONF_OPT = --disable-protoc