Cleanup libxml2
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 7 Aug 2007 17:27:59 +0000 (17:27 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 7 Aug 2007 17:27:59 +0000 (17:27 -0000)
package/libxml2/Config.in
package/libxml2/libxml2.mk

index 8c252b09d50cffbf353a36e1dfbf653f7ef31223..0e383d68277a144b56be81a1eae9cb081e151df8 100644 (file)
@@ -1,19 +1,15 @@
 config BR2_PACKAGE_LIBXML2
        bool "libxml2"
        default n
-       depends on BR2_USE_WCHAR
        help
          XML C Parser
-         Requires WCHAR
-
          ftp://xmlsoft.org/libxml2
 
 config BR2_PACKAGE_LIBXML2_TARGET_HEADERS
        bool "libxml2 target headers"
        default n
+       depends on BR2_PACKAGE_LIBXML2
        help
          XML C Parser
-         Requires WCHAR
-
          ftp://xmlsoft.org/libxml2
 
index d9e2a35e65100630499f162aa2027c49ef16ec26..17bba150b3424759833768e9578fd7182264c13b 100644 (file)
@@ -26,8 +26,23 @@ $(LIBXML2_DIR)/.configured: $(LIBXML2_DIR)/.unpacked
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
                --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
                --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               --includedir=/usr/include \
+               --with-gnu-ld \
                --enable-shared \
+               --enable-static \
+               --enable-ipv6=no \
+               --without-debugging \
+               --without-python \
+               --without-threads \
                $(DISABLE_NLS) \
        );
        touch $(LIBXML2_DIR)/.configured
@@ -38,6 +53,10 @@ $(LIBXML2_DIR)/libxml2.la: $(LIBXML2_DIR)/.configured
 
 $(STAGING_DIR)/usr/lib/libxml2.so: $(LIBXML2_DIR)/libxml2.la
        $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBXML2_DIR) install
+       rm -f $(STAGING_DIR)/usr/lib/libxml2.la
+       $(SED) 's:prefix=/usr:prefix=$(STAGING_DIR)/usr:' \
+               -e 's:includedir=/usr/include:includedir=$(STAGING_DIR)/usr/include:' \
+               $(STAGING_DIR)/usr/bin/xml2-config
 
 $(TARGET_DIR)/usr/lib/libxml2.so: $(STAGING_DIR)/usr/lib/libxml2.so
        cp -dpf $(STAGING_DIR)/usr/lib/libxml2.so* $(TARGET_DIR)/usr/lib/