apitrace: do not use bundled version of libpng
authorJérôme Pouiller <jezz@sysmic.org>
Sat, 21 Nov 2015 11:09:36 +0000 (12:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Nov 2015 13:05:39 +0000 (14:05 +0100)
In case libpng is not found apitrace its own version of libpng. However
current bundled version (1.1.16) is impacted by
https://sourceforge.net/p/libpng/bugs/230/. We simplify problem by
forcing use of external libpng.

Notice this patch also impact use of zlib. Apitrace also use its own
version of zlib if none was found. Since we select libpng, external
zlib is also selected.

Fix:
  http://autobuild.buildroot.net/results/ac790191127cf4d8b19d0c7c640981264772f503/

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/apitrace/Config.in
package/apitrace/apitrace.mk

index 4fe82aa1b61c656b944d63a490065e8e6c7fb0c1..a977712818617ef45010bfd0a3fcb913f1e7b43a 100644 (file)
@@ -10,6 +10,7 @@ config BR2_PACKAGE_APITRACE
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_6
        depends on BR2_PACKAGE_XORG7
        select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_LIBPNG
        help
          Trace and replay OpenGL and OpenGL ES APIs calls to/from a
          file. You may install apitrace GUI from your distribution to
index 28a40e4e201bcb4add98e9712640e87e72c0fbff..fbd957c617571b9bd17a00db22067ee527e8066c 100644 (file)
@@ -9,7 +9,7 @@ APITRACE_SITE = $(call github,apitrace,apitrace,$(APITRACE_VERSION))
 APITRACE_LICENSE = MIT
 APITRACE_LICENSE_FILES = LICENSE
 
-APITRACE_DEPENDENCIES = xlib_libX11 host-python
+APITRACE_DEPENDENCIES = xlib_libX11 host-python libpng
 
 # Gui was never tested, so we prefer to explicitly disable it
 APITRACE_CONF_OPTS += -DENABLE_GUI=false