iptables: bump to version 1.6.2
authorAntoine Tenart <antoine.tenart@bootlin.com>
Fri, 23 Feb 2018 09:52:00 +0000 (10:52 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Feb 2018 15:52:06 +0000 (16:52 +0100)
Also removed a patch fixing the build with musl as it made its way into
the 1.6.2 version.

Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iptables/0001-utils-nfsynproxy-fix-build-with-musl-libc.patch [deleted file]
package/iptables/iptables.hash
package/iptables/iptables.mk

diff --git a/package/iptables/0001-utils-nfsynproxy-fix-build-with-musl-libc.patch b/package/iptables/0001-utils-nfsynproxy-fix-build-with-musl-libc.patch
deleted file mode 100644 (file)
index 1f86ad1..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From 06e0312d0bfd1f0b9e7c23ab654f18524d49e86b Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Thu, 2 Mar 2017 09:20:48 +0200
-Subject: [PATCH] utils: nfsynproxy: fix build with musl libc
-
-The musl libc exposes some struct tcphdr field only when _GNU_SOURCE is
-defined. Fix the following build failure:
-
-nfsynproxy.c: In function ‘parse_packet’:
-nfsynproxy.c:34:9: error: ‘const struct tcphdr’ has no member named ‘syn’
-  if (!th->syn || !th->ack)
-         ^
-nfsynproxy.c:34:21: error: ‘const struct tcphdr’ has no member named ‘ack’
-  if (!th->syn || !th->ack)
-                     ^
-nfsynproxy.c:42:8: error: ‘const struct tcphdr’ has no member named ‘res2’
-  if (th->res2 == 0x1)
-        ^
-nfsynproxy.c:45:13: error: ‘const struct tcphdr’ has no member named ‘doff’
-  length = th->doff * 4 - sizeof(*th);
-             ^
-
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
-Upstream status: pending (http://patchwork.ozlabs.org/patch/734503/)
-
- utils/nfsynproxy.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/utils/nfsynproxy.c b/utils/nfsynproxy.c
-index baedc92c5d9f..bf5c416340f1 100644
---- a/utils/nfsynproxy.c
-+++ b/utils/nfsynproxy.c
-@@ -6,6 +6,7 @@
-  * published by the Free Software Foundation.
-  */
-+#define _GNU_SOURCE
- #include <stdlib.h>
- #include <stdbool.h>
- #include <unistd.h>
--- 
-2.11.0
-
index b673c8abdbb4f7c05716b8ba586a78422eb5a8c0..8b191797fb8293dffafd2e3698afca790f1b5920 100644 (file)
@@ -1,3 +1,3 @@
-# From ftp://ftp.netfilter.org/pub/iptables/iptables-1.6.1.tar.bz2.{md5sum,sha1sum}
-md5    ab38a33806b6182c6f53d6afb4619add        iptables-1.6.1.tar.bz2
-sha1   b2592490ca7a6c2cd0f069e167a4337c86acdf91        iptables-1.6.1.tar.bz2
+# From ftp://ftp.netfilter.org/pub/iptables/iptables-1.6.2.tar.bz2.{md5sum,sha1sum}
+md5    7d2b7847e4aa8832a18437b8a4c1873d        iptables-1.6.2.tar.bz2
+sha1   6279effbf8f2c7ff53d19ae13308f8a6e6a60dd9        iptables-1.6.2.tar.bz2
index 44cfde2b9a6c12160549d22664acc833674f9e35..49a537f6080a045401545e281ce82fdf63df38f9 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IPTABLES_VERSION = 1.6.1
+IPTABLES_VERSION = 1.6.2
 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
 IPTABLES_INSTALL_STAGING = YES