package/imagemagick: disable locale with uclibc
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 9 Mar 2019 14:51:25 +0000 (15:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 15 Mar 2019 22:01:51 +0000 (23:01 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/f7be30ffa28b7f367fb5343a7d69dc8bc7c3a170

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/imagemagick/imagemagick.mk

index b5d0d56284f1803676737aef51d75f1695fe62a9..81e49eb62c71adef4a60aabc707b232e90c58941 100644 (file)
@@ -40,6 +40,14 @@ IMAGEMAGICK_CONF_OPTS = \
 
 IMAGEMAGICK_DEPENDENCIES = host-pkgconf
 
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+# Like postgreSQL, imagemagick does not build against uClibc with
+# locales enabled, due to an uClibc bug, see
+# http://lists.uclibc.org/pipermail/uclibc/2014-April/048326.html
+# so overwrite automatic detection and disable locale support
+IMAGEMAGICK_CONF_ENV += ac_cv_func_newlocale=no
+endif
+
 ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
 IMAGEMAGICK_CONF_OPTS += --with-fontconfig
 IMAGEMAGICK_DEPENDENCIES += fontconfig