projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
759e150
)
toolchain/gcc-4.x: strip cross libgcc / libstdc++
author
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 17 Jun 2008 13:28:37 +0000
(13:28 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 17 Jun 2008 13:28:37 +0000
(13:28 -0000)
toolchain/gcc/gcc-uclibc-4.x.mk
patch
|
blob
|
history
diff --git
a/toolchain/gcc/gcc-uclibc-4.x.mk
b/toolchain/gcc/gcc-uclibc-4.x.mk
index 5365cdff1459fcfb1a3abed8d796f806c4d19504..819f2b20c8f8fd0a38862dfe22f3630e51e5bcde 100644
(file)
--- a/
toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/
toolchain/gcc/gcc-uclibc-4.x.mk
@@
-349,11
+349,13
@@
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
-cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* \
$(TARGET_DIR)/lib/
+ -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/lib/libgcc_s*
endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
-cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libstdc++.so* \
$(TARGET_DIR)/usr/lib/
+ -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/usr/lib/libstdc++.so*
endif
endif
ifeq ($(BR2_INSTALL_LIBGCJ),y)