package/collectd: add redis support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 9 Jun 2019 22:51:18 +0000 (00:51 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 10 Jun 2019 13:30:12 +0000 (15:30 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/collectd/Config.in
package/collectd/collectd.mk

index 31103634293825be43de8cfbdc643303405a7dd5..79794108718ac9ae2b0760ab8e7ace21812e4e02 100644 (file)
@@ -404,6 +404,12 @@ config BR2_PACKAGE_COLLECTD_PROTOCOLS
        help
          Collects information about the network protocols.
 
+config BR2_PACKAGE_COLLECTD_REDIS
+       bool "redis"
+       select BR2_PACKAGE_HIREDIS
+       help
+         Connects to one or more instances of Redis.
+
 config BR2_PACKAGE_COLLECTD_SENSORS
        bool "sensors"
        select BR2_PACKAGE_LM_SENSORS
index 531b824b268bb325b3bc25b44f57098636ea6546..ddafd0619020ff4026b2aeff8a72ca5a68ebbc6a 100644 (file)
@@ -17,7 +17,7 @@ COLLECTD_PLUGINS_DISABLE = \
        apple_sensors aquaero ascent barometer dbi dpdkstat email \
        gmond grpc hddtemp intel_rdt ipmi java libvirt lpar lua lvm \
        madwifi mbmon mic multimeter netapp notify_desktop numa \
-       nut onewire oracle perl pf pinba powerdns python redis routeros \
+       nut onewire oracle perl pf pinba powerdns python routeros \
        rrdcached sigrok tape target_v5upgrade teamspeak2 ted \
        tokyotyrant turbostat uuid varnish virt vserver write_kafka \
        write_mongodb write_redis xencpu xmms zfs_arc zone
@@ -107,6 +107,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_POSTGRESQL),--enable-postgresql,--disable-postgresql) \
        $(if $(BR2_PACKAGE_COLLECTD_PROCESSES),--enable-processes,--disable-processes) \
        $(if $(BR2_PACKAGE_COLLECTD_PROTOCOLS),--enable-protocols,--disable-protocols) \
+       $(if $(BR2_PACKAGE_COLLECTD_REDIS),--enable-redis,--disable-redis) \
        $(if $(BR2_PACKAGE_COLLECTD_REGEX),--enable-match_regex,--disable-match-regex) \
        $(if $(BR2_PACKAGE_COLLECTD_REPLACE),--enable-target_replace,--disable-target_replace) \
        $(if $(BR2_PACKAGE_COLLECTD_RIEMANN),--enable-write_riemann,--disable-write_riemann) \
@@ -163,6 +164,7 @@ COLLECTD_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_COLLECTD_OPENLDAP),openldap) \
        $(if $(BR2_PACKAGE_COLLECTD_PING),liboping) \
        $(if $(BR2_PACKAGE_COLLECTD_POSTGRESQL),postgresql) \
+       $(if $(BR2_PACKAGE_COLLECTD_REDIS),hiredis) \
        $(if $(BR2_PACKAGE_COLLECTD_RIEMANN),libtool riemann-c-client) \
        $(if $(BR2_PACKAGE_COLLECTD_RRDTOOL),rrdtool) \
        $(if $(BR2_PACKAGE_COLLECTD_SENSORS),lm-sensors) \