package/python-pillow: add xcb support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 22 May 2021 17:41:57 +0000 (19:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 May 2021 08:30:35 +0000 (10:30 +0200)
libxcb is an optional dependency since version 7.1.0 and
https://github.com/python-pillow/Pillow/commit/3c39e6fcf6a11b18eec0d1c66710bcd35033d069

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python-pillow/python-pillow.mk

index 3018758b4841b81ffb66ce2f1e85a8b6e9fded1f..ab52f38df1d8f408fec0191123a6efd1d6aa4e64 100644 (file)
@@ -35,6 +35,13 @@ else
 PYTHON_PILLOW_BUILD_OPTS += --disable-lcms
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCB),y)
+PYTHON_PILLOW_DEPENDENCIES += libxcb
+PYTHON_PILLOW_BUILD_OPTS += --enable-xcb
+else
+PYTHON_PILLOW_BUILD_OPTS += --disable-xcb
+endif
+
 ifeq ($(BR2_PACKAGE_OPENJPEG),y)
 PYTHON_PILLOW_DEPENDENCIES += openjpeg
 PYTHON_PILLOW_BUILD_OPTS += --enable-jpeg2000