libv4l: disable clang
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 3 Nov 2018 14:06:09 +0000 (15:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 3 Nov 2018 14:55:44 +0000 (15:55 +0100)
For the time being, disable clang that is used to build BPF (in-kernel
bytecode machine) protocols.
Indeed, if an old version of clang is found on the host, it could be
used to build object files with a "None" architecture which will be
rejected by support/scripts/check-bin-arch

Fixes:
 - http://autobuild.buildroot.org/results/c18fb7f1ac81496db9c3a4e91ea028a26ca600b0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libv4l/libv4l.mk

index 4e82dea6ad95d25b2dd0426bb7287c5da683c41f..f473c03806367b50680af231c81ee86b5e015014 100644 (file)
@@ -55,6 +55,10 @@ endif
 ifeq ($(BR2_PACKAGE_LIBV4L_UTILS),y)
 LIBV4L_CONF_OPTS += --enable-v4l-utils
 LIBV4L_DEPENDENCIES += $(TARGET_NLS_DEPENDENCIES)
+
+# Disable clang that is used to build BPF (in-kernel bytecode machine) protocols
+LIBV4L_CONF_ENV += ac_cv_prog_CLANG=""
+
 ifeq ($(BR2_PACKAGE_QT5BASE)$(BR2_PACKAGE_QT5BASE_GUI)$(BR2_PACKAGE_QT5BASE_WIDGETS),yyy)
 LIBV4L_CONF_OPTS += --enable-qv4l2
 LIBV4L_DEPENDENCIES += qt5base