fs/common: Create initial console device
authorMarkos Chandras <markos.chandras@imgtec.com>
Sun, 4 Nov 2012 23:44:54 +0000 (23:44 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 21 Nov 2012 10:31:33 +0000 (11:31 +0100)
A /dev/console node must be present in rootfs when the Linux kernel
boots otherwise the kernel will print the following warning:
"Warning: unable to open an initial console"

This is because when we use an initramfs the /dev directory is not
populated at this point. This can cause problems when a program
(e.g ldso with early debugging enabled) opens a standard file
descriptor for read/write before these descriptors are actually
created by the init process later on.

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/cpio/cpio.mk

index aa20b41074101995fb0c0d6f8aee6316a8c225f9..5533322d1c97bef1d32c21a8ed62adb54c430ecc 100644 (file)
@@ -21,6 +21,8 @@ define ROOTFS_CPIO_ADD_INIT
         fi
 endef
 
+PACKAGES_PERMISSIONS_TABLE += /dev/console c 622 0 0 5 1 - - -$(sep)
+
 endif # BR2_ROOTFS_DEVICE_CREATION_STATIC
 
 ROOTFS_CPIO_PRE_GEN_HOOKS += ROOTFS_CPIO_ADD_INIT