package/asterisk: add support for dahdi
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:29 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
DAHDI is the 'framework' to drive actual telehony cards. Using telephony
cards without signalling is pretty much meaningless, so signalling will
be added in later commits.

libtonezone is provided by dhadi-tools, while the dahdi headers are
provided by dahdi-linux. Go figure.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index e674565db1c1fd55125be1084eac9d2bd09ffe76..55370c43b80ade088ba82995cd0b26e6f9d5d1bc 100644 (file)
@@ -52,7 +52,6 @@ ASTERISK_CONF_OPTS = \
        --without-cap \
        --without-cpg \
        --without-curses \
-       --without-dahdi \
        --without-gtk2 \
        --without-gmime \
        --without-h323 \
@@ -95,7 +94,6 @@ ASTERISK_CONF_OPTS = \
        --without-termcap \
        --without-timerfd \
        --without-tinfo \
-       --without-tonezone \
        --without-unbound \
        --without-unixodbc \
        --without-vpb \
@@ -196,6 +194,13 @@ else
 ASTERISK_CONF_OPTS += --without-radius
 endif
 
+ifeq ($(BR2_PACKAGE_DAHDI_LINUX)$(BR2_PACKAGE_DAHDI_TOOLS),yy)
+ASTERISK_DEPENDENCIES += dahdi-linux dahdi-tools
+ASTERISK_CONF_OPTS += --with-dahdi --with-tonezone
+else
+ASTERISK_CONF_OPTS += --without-dahdi --without-tonezone
+endif # DAHDI
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 ASTERISK_DEPENDENCIES += openssl
 ASTERISK_CONF_OPTS += --with-ssl