infra: remove separate definition of DISABLE_DOCUMENTATION
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 5 Feb 2014 13:51:00 +0000 (14:51 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Feb 2014 22:44:48 +0000 (23:44 +0100)
Since we now always disable documentation on target, there is no need to
have a separate variable DISABLE_DOCUMENTATION anymore.

Suggested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Makefile.in
package/pkg-autotools.mk

index a8f565027762939494e35d2773e2f10d7ee946f5..9d0e7d60ed5e350177046eeac6162751f8ad87c1 100644 (file)
@@ -332,16 +332,6 @@ ifneq ($(BR2_LARGEFILE),y)
 DISABLE_LARGEFILE= --disable-largefile
 endif
 
-# The configure option varies, but since unknown options are ignored
-# we can pass all of them.
-DISABLE_DOCUMENTATION = \
-       --disable-gtk-doc \
-       --disable-doc \
-       --disable-docs \
-       --disable-documentation \
-       --with-xmlto=no \
-       --with-fop=no
-
 ifeq ($(BR2_INET_IPV6),y)
 DISABLE_IPV6= --enable-ipv6
 else
index cfbdc271612ca4bb14bdc1092248b66ec4b3a760..6f523353bb748357858129f4f5bb5b5ce437149f 100644 (file)
@@ -109,7 +109,12 @@ define $(2)_CONFIGURE_CMDS
                --exec-prefix=/usr \
                --sysconfdir=/etc \
                --program-prefix="" \
-               $$(DISABLE_DOCUMENTATION) \
+               --disable-gtk-doc \
+               --disable-doc \
+               --disable-docs \
+               --disable-documentation \
+               --with-xmlto=no \
+               --with-fop=no
                $$(DISABLE_NLS) \
                $$(DISABLE_LARGEFILE) \
                $$(DISABLE_IPV6) \