libfslparser: bump to version 4.0.7
authorGary Bisson <gary.bisson@boundarydevices.com>
Sat, 30 Jan 2016 11:45:53 +0000 (12:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Feb 2016 20:46:08 +0000 (21:46 +0100)
Changelog:
- Add h264 parser version.
- Support wide and 'ms 0x0 0x11' adpcm tag.
- Support hev1 tag for hevc video codec.
- TS segment fault.
- Improve mkv parser's loading time when create parser with large size
file.

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/6406ad4
https://github.com/Freescale/meta-fsl-arm/commit/09a532c
https://github.com/Freescale/meta-fsl-arm/commit/371df94

This package has been implicitely tested through gstreamer as the 0.10
plugin relies on it:
 # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfslparser/libfslparser.hash
package/libfslparser/libfslparser.mk

index 19ee12e85769fd1f1fdf445dbcaf9e68615990b4..976a2d21d60747057cba48d14837581c961f9dd0 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed
-sha256 9db10ca6a61c8fdbe91b55b65d084dcbb5f9cfb58b088996c7dd2d6dc8385730  libfslparser-4.0.3.bin
+sha256 e7c248e64db03c3ddd84f50ae408e560f8f5819e58c487a5dec5141bc384ae83  libfslparser-4.0.7.bin
index 2b53d6293a978168f01ab95d6e6db9e203d3ce65..c5efc85c9af227625ee8dabce2b5f693cef0a440 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBFSLPARSER_VERSION = 4.0.3
+LIBFSLPARSER_VERSION = 4.0.7
 LIBFSLPARSER_SITE = $(FREESCALE_IMX_SITE)
 LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
 LIBFSLPARSER_INSTALL_STAGING = YES