package/libcec: Bump to version 2.2.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 23 Dec 2014 17:46:25 +0000 (18:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Dec 2014 19:52:43 +0000 (20:52 +0100)
Kodi Helix depends on libcec >= 2.2.0

Removed libcec-0001-Fix-unregistering-a-callback-that-wasn-t-register.patch
applied upstream: https://github.com/Pulse-Eight/libcec/commit/485660f

Renamed remaining patch according to new naming convention.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libcec/0001-no-psabi-warning.patch [new file with mode: 0644]
package/libcec/libcec-0001-Fix-unregistering-a-callback-that-wasn-t-register.patch [deleted file]
package/libcec/libcec-0002-no-psabi-warning.patch [deleted file]
package/libcec/libcec.mk

diff --git a/package/libcec/0001-no-psabi-warning.patch b/package/libcec/0001-no-psabi-warning.patch
new file mode 100644 (file)
index 0000000..bd6557e
--- /dev/null
@@ -0,0 +1,22 @@
+Do not use -Wno-psabi warning, not available on old g++
+
+AVR32 uses a very old g++ version, which does not implement the
+-Wno-psabi warning flag. This patch simply removes this warning flag
+from the libcec build. It can be dropped if only gcc 4.5+ versions are
+supported in Buildroot.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -130,7 +130,7 @@
+ use_udev="no"
+ use_adapter_detection="yes"
+ use_lockdev="no"
+-SUPPRESS_MANGLING_WARNINGS=" -Wno-psabi"
++SUPPRESS_MANGLING_WARNINGS=""
+ case "${host}" in
+   *-*-linux*)
+     ## search for udev if pkg-config was found
diff --git a/package/libcec/libcec-0001-Fix-unregistering-a-callback-that-wasn-t-register.patch b/package/libcec/libcec-0001-Fix-unregistering-a-callback-that-wasn-t-register.patch
deleted file mode 100644 (file)
index 41d93aa..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 78e52d55d6fc079b9a96d1a663d1991d9a0f2a2b Mon Sep 17 00:00:00 2001
-From: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
-Date: Wed, 7 May 2014 08:41:27 +0200
-Subject: [PATCH] Fix unregistering a callback that wasn't register
-
-This patchs fixes an asserts that get's thrown when you start XBMC and thus
-prevents it from starting.
-The asserts you'll endup getting is:
-assertion failure:
-[...]/interface/vmcs_host/vc_vchi_tvservice.c:430:vc_tv_unregister_callback():done
-
-Found: https://github.com/raspberrypi/userland/issues/159
-
-Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
----
- src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp b/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp
-index 76c61b3..1eb6417 100644
---- a/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp
-+++ b/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp
-@@ -353,7 +353,9 @@ void CRPiCECAdapterCommunication::Close(void)
-     else
-       return;
-   }
--  vc_tv_unregister_callback(rpi_tv_callback);
-+
-+  if (m_bInitialised)
-+    vc_tv_unregister_callback(rpi_tv_callback);
-
-   UnregisterLogicalAddress();
-
---
-1.9.2
-
diff --git a/package/libcec/libcec-0002-no-psabi-warning.patch b/package/libcec/libcec-0002-no-psabi-warning.patch
deleted file mode 100644 (file)
index bd6557e..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Do not use -Wno-psabi warning, not available on old g++
-
-AVR32 uses a very old g++ version, which does not implement the
--Wno-psabi warning flag. This patch simply removes this warning flag
-from the libcec build. It can be dropped if only gcc 4.5+ versions are
-supported in Buildroot.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/configure.ac
-===================================================================
---- a/configure.ac
-+++ b/configure.ac
-@@ -130,7 +130,7 @@
- use_udev="no"
- use_adapter_detection="yes"
- use_lockdev="no"
--SUPPRESS_MANGLING_WARNINGS=" -Wno-psabi"
-+SUPPRESS_MANGLING_WARNINGS=""
- case "${host}" in
-   *-*-linux*)
-     ## search for udev if pkg-config was found
index 5a889b9c60030324cb87ceae8e94d9a09a96886f..8bdc9ea0fd23d317d1410e52967369107f01e3ee 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBCEC_VERSION = libcec-2.1.4-repack
+LIBCEC_VERSION = libcec-2.2.0-repack
 LIBCEC_SITE = $(call github,Pulse-Eight,libcec,$(LIBCEC_VERSION))
 LIBCEC_LICENSE = GPLv2+
 LIBCEC_LICENSE_FILES = COPYING