package/mesa3d: add xvmc option
authorRomain Naour <romain.naour@smile.fr>
Sat, 21 Sep 2019 18:10:47 +0000 (20:10 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 21 Sep 2019 18:20:51 +0000 (20:20 +0200)
"XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau."

https://cgit.freedesktop.org/mesa/mesa/commit/?id=22a817af8a89eb3c762fc3e07b443a3ce37d7416

Signed-off-by: Romain Naour <romain.naour@smile.fr>
[moved Config.in option into Gallium block, fixed comment dependency]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index bfba68f867f103ece2e389d6b7ce88b3e0d7303e..9baa82376e14bb02236192e204356c0359d926e5 100644 (file)
@@ -193,6 +193,22 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VIRGL
          virgl is the 3D acceleration backend for the virtio-gpu
          shipping with qemu.
 
+config BR2_PACKAGE_MESA3D_XVMC
+       bool "Gallium XvMC state tracker"
+       depends on BR2_i386 || BR2_x86_64
+       depends on BR2_PACKAGE_XORG7
+       depends on BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU \
+               || BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600
+       select BR2_PACKAGE_XLIB_LIBXVMC
+       help
+         XvMC state tracker (needs r600 or nouveau gallium drivers).
+
+comment "Gallium XvMC state tracker needs X.org and gallium drivers r600 or nouveau"
+       depends on BR2_i386 || BR2_x86_64
+       depends on !BR2_PACKAGE_XORG7 || \
+               !(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU \
+               || BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600)
+
 comment "DRI drivers"
 
 config BR2_PACKAGE_MESA3D_DRI_DRIVER_SWRAST
index 107b4dfeb8a2cc141574690042c0bd52651b48b3..1987cb358a914bdb2e9dc6eff21f8d3f9d1369ae 100644 (file)
@@ -219,7 +219,7 @@ else
 MESA3D_CONF_OPTS += --disable-gles1 --disable-gles2
 endif
 
-ifeq ($(BR2_PACKAGE_XLIB_LIBXVMC),y)
+ifeq ($(BR2_PACKAGE_MESA3D_XVMC),y)
 MESA3D_DEPENDENCIES += xlib_libXvMC
 MESA3D_CONF_OPTS += --enable-xvmc
 else