wipe: ensure binary gets installed with proper permissions
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:08:46 +0000 (23:08 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:08:46 +0000 (23:08 +0100)
Reported-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wipe/wipe.mk

index ee4682c5a458611e8cedbc9f9c37cbfefb476280..38cb434b4edb6c22363d64a1e853a675a069bb30 100644 (file)
@@ -12,7 +12,7 @@ WIPE_LICENSE = GPLv2+
 WIPE_LICENSE_FILES = LICENSE
 
 define WIPE_INSTALL_TARGET_CMDS
-       $(INSTALL) -D $(@D)/wipe $(TARGET_DIR)/usr/bin/wipe
+       $(INSTALL) -D -m 0755 $(@D)/wipe $(TARGET_DIR)/usr/bin/wipe
 endef
 
 $(eval $(autotools-package))