gst1-plugins-bad: bump version to 1.12.0
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 12 May 2017 10:18:01 +0000 (11:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Jul 2017 11:31:16 +0000 (13:31 +0200)
Remove non-existant configure options:

  --disable-mimic:
    https://github.com/GStreamer/gst-plugins-bad/commit/ad661999ad2c79a5d7721f0eb1e7f1f83a304224

  --enable-dataurisrc:
    https://github.com/GStreamer/gst-plugins-bad/commit/de4bb6e1d4793637fd72d7316d06ebba4148583e

  --enable-videomeasure:
    https://github.com/GStreamer/gst-plugins-bad/commit/ca3020cf46d49d8e3fd54ec323b3a17cd389d780

  --enable-apexsink, --disable-nas, --disable-linsys, --enable-sdl,
  --disable-sdltest, --disable-libvisual, --disable-timidity,
  --disable-sndio, --disable-wininet, --disable-xvid,
  --enable-cdxaparse, --enable-dccp, --enable-hdvparse, --enable-mve,
  --enable-nuvdemux, --enable-patchdetect, --enable-sdi, --enable-tta,
  --disable-pvr:
    https://github.com/GStreamer/gst-plugins-bad/commit/9b5de053995488d5ddc78c1bf4df651101271d70

[Peter: split out webrtc rename to a separate patch, tweak dataurisrc help]
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.hash
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index b8fe028376ff08df405e60310b7a051d200dfc6e..f20eb6a4d21d96e1176385cd503d26f8c8b6ada1 100644 (file)
@@ -145,6 +145,56 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.08"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CDXAPARSE
+       bool "cdxaparse removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DATAURISRC
+       bool "dataurisrc moved to gstreamer1"
+       select BR2_LEGACY
+       help
+         Dataurisrc has moved to gstreamer core and is always built.
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DCCP
+       bool "dccp removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_HDVPARSE
+       bool "hdvparse removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MVE
+       bool "mve removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NUVDEMUX
+       bool "nuvdemux removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PATCHDETECT
+       bool "patchdetect removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI
+       bool "sdi removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA
+       bool "tta removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOMEASURE
+       bool "videomeasure removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_APEXSINK
+       bool "apexsink removed"
+       select BR2_LEGACY
+
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL
+       bool "sdl removed"
+       select BR2_LEGACY
+
 config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MAD
        bool "mad (*.mp3 audio) removed"
        select BR2_LEGACY
index fd3ca938c4fcfdcab5e43098eadf18118bf3e37a..d137a6c2538445e423a45dd976213648ddf3376e 100644 (file)
@@ -199,22 +199,11 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CAMERABIN2
        help
          Take image snapshots and record movies from camera
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CDXAPARSE
-       bool "cdxaparse"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_COLOREFFECTS
        bool "coloreffects"
        help
          Color Look-up Table filters
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DATAURISRC
-       bool "dataurisrc"
-       help
-         data: URI source
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DCCP
-       bool "dccp"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DEBUGUTILS
        bool "debugutils"
        help
@@ -274,9 +263,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GDP
        help
          Payload/depayload GDP packets
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_HDVPARSE
-       bool "hdvparse"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ID3TAG
        bool "id3tag"
        help
@@ -338,9 +324,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPEGPSMUX
        help
          MPEG-PS muxer
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MVE
-       bool "mve"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MXF
        bool "mxf"
        help
@@ -349,15 +332,9 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MXF
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NETSIM
        bool "netsim"
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NUVDEMUX
-       bool "nuvdemux"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ONVIF
        bool "onvif"
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PATCHDETECT
-       bool "patchdetect"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PCAPPARSE
        bool "pcapparse"
        help
@@ -384,9 +361,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTMP
        help
          RTMP plugin
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI
-       bool "sdi"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDP
        bool "sdp"
        help
@@ -423,9 +397,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_STEREO
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TIMECODE
        bool "timecode"
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA
-       bool "tta"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOFILTERS
        bool "videofilters"
        help
@@ -436,9 +407,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOFRAME_AUDIOLEVEL
        help
          videoframe_audiolevel
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOMEASURE
-       bool "videomeasure"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOPARSERS
        bool "videoparsers"
        help
@@ -462,10 +430,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_YADIF
 
 comment "plugins with external dependencies"
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_APEXSINK
-       bool "apexsink"
-       select BR2_PACKAGE_OPENSSL
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ASSRENDER
        bool "assrender"
        select BR2_PACKAGE_LIBASS
@@ -660,10 +624,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SBC
        bool "sbc"
        select BR2_PACKAGE_SBC
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL
-       bool "sdl"
-       select BR2_PACKAGE_SDL
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SHM
        bool "shm"
        help
index 441afa2c521417231353d3409d90cb69d774a7ca..68781dda6256e66681fd5c5107bc22a5d8b28f5d 100644 (file)
@@ -1,2 +1,2 @@
-# From http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.10.4.tar.xz.sha256sum
-sha256 23ddae506b3a223b94869a0d3eea3e9a12e847f94d2d0e0b97102ce13ecd6966  gst-plugins-bad-1.10.4.tar.xz
+# From http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.12.0.tar.xz.sha256sum
+sha256 11b73cfff1b315a8e9be1756435ea84937e7cb90afbab0e8e6975367dbfb8534  gst-plugins-bad-1.12.0.tar.xz
index 46dd14ccb7b471119b6dfe38c7e119ed5db2d401..9dbde1489befc8dfc146458f0681bdcdbc453c71 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GST1_PLUGINS_BAD_VERSION = 1.10.4
+GST1_PLUGINS_BAD_VERSION = 1.12.0
 GST1_PLUGINS_BAD_SOURCE = gst-plugins-bad-$(GST1_PLUGINS_BAD_VERSION).tar.xz
 GST1_PLUGINS_BAD_SITE = https://gstreamer.freedesktop.org/src/gst-plugins-bad
 GST1_PLUGINS_BAD_INSTALL_STAGING = YES
@@ -21,8 +21,6 @@ GST1_PLUGINS_BAD_CONF_OPTS = \
        --disable-winks \
        --disable-android_media \
        --disable-apple_media \
-       --disable-sdltest \
-       --disable-wininet \
        --disable-acm
 
 # Options which require currently unpackaged libraries
@@ -44,29 +42,21 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-ladspa \
        --disable-lv2 \
        --disable-libde265 \
-       --disable-linsys \
        --disable-modplug \
-       --disable-mimic \
        --disable-mplex \
-       --disable-nas \
        --disable-ofa \
        --disable-openexr \
        --disable-openni2 \
-       --disable-pvr \
-       --disable-libvisual \
-       --disable-timidity \
        --disable-teletextdec \
        --disable-wildmidi \
        --disable-smoothstreaming \
        --disable-soundtouch \
        --disable-spc \
        --disable-gme \
-       --disable-xvid \
        --disable-vdpau \
        --disable-schro \
        --disable-zbar \
        --disable-spandsp \
-       --disable-sndio \
        --disable-gtk3 \
        --disable-qt
 
@@ -218,30 +208,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-camerabin2
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CDXAPARSE),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-cdxaparse
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-cdxaparse
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_COLOREFFECTS),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-coloreffects
 else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-coloreffects
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DATAURISRC),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-dataurisrc
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-dataurisrc
-endif
-
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DCCP),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-dccp
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-dccp
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DEBUGUTILS),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-debugutils
 else
@@ -315,12 +287,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-gdp
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_HDVPARSE),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-hdvparse
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-hdvparse
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ID3TAG),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-id3tag
 else
@@ -401,12 +367,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-mpegpsmux
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MVE),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-mve
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-mve
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MXF),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-mxf
 else
@@ -419,24 +379,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-netsim
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NUVDEMUX),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-nuvdemux
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-nuvdemux
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ONVIF),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-onvif
 else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-onvif
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PATCHDETECT),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-patchdetect
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-patchdetect
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PCAPPARSE),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-pcapparse
 else
@@ -468,12 +416,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-rtmp
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdi
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-sdi
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDP),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdp
 else
@@ -522,12 +464,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-timecode
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-tta
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-tta
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOFILTERS),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-videofilters
 else
@@ -540,12 +476,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-videoframe_audiolevel
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOMEASURE),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-videomeasure
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-videomeasure
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VIDEOPARSERS),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-videoparsers
 else
@@ -578,13 +508,6 @@ endif
 
 # Plugins with dependencies
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_APEXSINK),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-apexsink
-GST1_PLUGINS_BAD_DEPENDENCIES += openssl
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-apexsink
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ASSRENDER),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-assrender
 GST1_PLUGINS_BAD_DEPENDENCIES += libass
@@ -765,14 +688,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-sbc
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL),y)
-GST1_PLUGINS_BAD_CONF_ENV += ac_cv_path_SDL_CONFIG=$(STAGING_DIR)/usr/bin/sdl-config
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdl
-GST1_PLUGINS_BAD_DEPENDENCIES += sdl
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-sdl
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SHM),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-shm
 else