squid: fix automake breakage
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 8 Jan 2015 01:09:27 +0000 (22:09 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Jan 2015 19:57:06 +0000 (20:57 +0100)
Squid bundles a copy of libltdl (from libtool) which autoreconfigures on
its own.
For some odd reason when automake was bumped to version 1.15 and if the host
system has another automake version, for example 1.14, the ACLOCAL and
AUTOMAKE variables don't expand properly when the internal autoreconf is
triggered hence calling the missing handler which in turn tries to use
an incorrect automake version.
The solution is to pass unexpanded ACLOCAL and AUTOMAKE variables that
defer the evaluation to a later moment and avoid the issue.

Fixes:
http://autobuild.buildroot.net/results/73f/73fcffafbea320f8c64378bbe8a96922b5e7c6b5/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/squid/squid.mk

index e9e821dd68f2861f103ed01fd1b5eba4ddea3cf3..403818a6aae1c04119f3ba1d0694edffc17c0c85 100644 (file)
@@ -20,7 +20,9 @@ SQUID_CONF_ENV = \
        ac_cv_func_va_copy=yes \
        ac_cv_func___va_copy=yes \
        ac_cv_func_strnstr=no \
-       ac_cv_have_squid=yes
+       ac_cv_have_squid=yes \
+       ACLOCAL="$(ACLOCAL)" \
+       AUTOMAKE="$(AUTOMAKE)"
 SQUID_CONF_OPTS = \
        --enable-async-io=8 \
        --enable-linux-netfilter \