luarocks: fix target-finalize hook processing
authorDanomi Manchego <danomimanchego123@gmail.com>
Sat, 24 Dec 2016 01:50:55 +0000 (20:50 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 28 Dec 2016 22:55:11 +0000 (23:55 +0100)
The LUAROCKS_TARGET_FINALIZE_HOOKS is not running, so detritus is being left
in /usr/lib/luarocks.  This is because host-luarocks is built by being a
dependency in the luarocks package infrastructure, not by being selected by
kconfig symbol.  This means that the $(PKG)_KCONFIG_VAR in pkg-generic.mk is
not met, and (HOST_)LUAROCKS_TARGET_FINALIZE_HOOKS is not added to the
global TARGET_FINALIZE_HOOKS.

This mod fixes this issue by adding the host-luarocks hook directly
to TARGET_FINALIZE_HOOKS when either lua or luajit is enabled.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/luarocks/luarocks.mk

index 4e0d537ff75064d2e45560f37c49b24db6c4659b..d18056a5279445007cf5b2ee503ef0dd818c7b1d 100644 (file)
@@ -60,4 +60,7 @@ define LUAROCKS_FINALIZE_TARGET
        rm -rf $(TARGET_DIR)/usr/lib/luarocks
 endef
 
-LUAROCKS_TARGET_FINALIZE_HOOKS += LUAROCKS_FINALIZE_TARGET
+# Apply to global variable directly, as pkg-generic does not
+ifneq ($(BR2_PACKAGE_LUAJIT)$(BR2_PACKAGE_LUA),)
+TARGET_FINALIZE_HOOKS += LUAROCKS_FINALIZE_TARGET
+endif