f2fs-tools: add selinux and libblk optional dependencies
authorBaruch Siach <baruch@tkos.co.il>
Tue, 12 Jun 2018 17:40:50 +0000 (20:40 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 12 Jun 2018 20:24:29 +0000 (22:24 +0200)
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/f2fs-tools/f2fs-tools.mk

index 333a2cf7d4ef9882392a76bc9b9cd084217f81a7..1736dc4ead004c28ac9442a7c73c93d72c47e2d9 100644 (file)
@@ -15,4 +15,18 @@ F2FS_TOOLS_INSTALL_STAGING = YES
 F2FS_TOOLS_LICENSE = GPL-2.0
 F2FS_TOOLS_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+F2FS_TOOLS_CONF_OPTS += --with-selinux
+F2FS_TOOLS_DEPENDENCIES += libselinux
+else
+F2FS_TOOLS_CONF_OPTS += --without-selinux
+endif
+
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),y)
+# util-linux is a dependency already, no need to list it again
+F2FS_TOOLS_CONF_OPTS += --with-blkid
+else
+F2FS_TOOLS_CONF_OPTS += --without-blkid
+endif
+
 $(eval $(autotools-package))