package/armadillo: fix build when host has hdf5
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Mon, 20 Apr 2020 16:07:48 +0000 (18:07 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 20 Apr 2020 21:27:50 +0000 (23:27 +0200)
When host computer has hdf5 library installed, armadillo fails to build with:

    [...]
    aarch64-buildroot-linux-gnu-g++: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/hdf5/serial'
    make[3]: *** [CMakeFiles/armadillo.dir/build.make:63: CMakeFiles/armadillo.dir/src/wrapper1.cpp.o] Error 1
    aarch64-buildroot-linux-gnu-g++: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/hdf5/serial'
    [...]

This issue seems known and is mentionned in a message, displayed at detection step:

    [...]
    -- *** If use of HDF5 is causing problems,
    -- *** rerun cmake with HDF5 detection disabled:
    -- *** cmake -D DETECT_HDF5=false .
    --
    [...]

nce hdf5 in not supported by buildroot, this patch force disabling this
detection.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
[yann.morin.1998@free.fr: fix pacakge name in title]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/armadillo/armadillo.mk

index d9a28e987866025abf1c1d39474722b11c8ff6c6..f693d8c9465ba89a0974020f0d9cc4100a5ca66b 100644 (file)
@@ -12,4 +12,6 @@ ARMADILLO_INSTALL_STAGING = YES
 ARMADILLO_LICENSE = Apache-2.0
 ARMADILLO_LICENSE_FILES = LICENSE.txt
 
+ARMADILLO_CONF_OPTS = -DDETECT_HDF5=false
+
 $(eval $(cmake-package))