gdb: add version 7.9
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 26 Mar 2015 23:01:01 +0000 (20:01 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Mar 2015 12:47:40 +0000 (14:47 +0200)
Add gdb version 7.9, and adjust the tarball logic to default to .tar.xz
(for 7.8 & 7.9), fall back to .tar.bz2 for 7.7.x and leave the rest
alone.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdb/Config.in.host
package/gdb/gdb.mk

index 2a03939981b8d2c858d5826966ae10da86635a66..cda9d123dbc8a6dfe4564e27bd2f75b93d56c2ee 100644 (file)
@@ -37,6 +37,9 @@ choice
        config BR2_GDB_VERSION_7_8
                bool "gdb 7.8.x"
 
+       config BR2_GDB_VERSION_7_9
+               bool "gdb 7.9.x"
+
 endchoice
 
 endif
@@ -49,3 +52,4 @@ config BR2_GDB_VERSION
        default "6be65fb56ea6694a9260733a536a023a1e2d4d57" if BR2_microblaze
        default "7.7.1"    if BR2_GDB_VERSION_7_7 || !BR2_PACKAGE_HOST_GDB
        default "7.8.2"    if BR2_GDB_VERSION_7_8
+       default "7.9"      if BR2_GDB_VERSION_7_9
index 58f0631a01728ce11f82cd11a30e5f19cfa6081b..3ae473fe72cf4ab3be549bbdbba96f2106eaedc8 100644 (file)
@@ -6,6 +6,7 @@
 
 GDB_VERSION = $(call qstrip,$(BR2_GDB_VERSION))
 GDB_SITE = $(BR2_GNU_MIRROR)/gdb
+GDB_SOURCE = gdb-$(GDB_VERSION).tar.xz
 
 ifeq ($(BR2_arc),y)
 GDB_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,binutils-gdb,$(GDB_VERSION))
@@ -19,13 +20,11 @@ GDB_SOURCE = gdb-$(GDB_VERSION).tar.gz
 GDB_FROM_GIT = y
 endif
 
-# Starting from 7.8.x, bz2 tarballs no longer available, use .tar.xz
-# instead.
-ifneq ($(filter 7.8.%,$(GDB_VERSION)),)
-GDB_SOURCE = gdb-$(GDB_VERSION).tar.xz
+# Use .tar.bz2 for 7.7.x since there was no .tar.xz release back then
+ifneq ($(filter 7.7.%,$(GDB_VERSION)),)
+GDB_SOURCE = gdb-$(GDB_VERSION).tar.bz2
 endif
 
-GDB_SOURCE ?= gdb-$(GDB_VERSION).tar.bz2
 GDB_LICENSE = GPLv2+ LGPLv2+ GPLv3+ LGPLv3+
 GDB_LICENSE_FILES = COPYING COPYING.LIB COPYING3 COPYING3.LIB