Patch from scott: http://bugs.uclibc.org/view.php?id=42
authorEric Andersen <andersen@codepoet.org>
Sun, 23 Jan 2005 11:20:30 +0000 (11:20 -0000)
committerEric Andersen <andersen@codepoet.org>
Sun, 23 Jan 2005 11:20:30 +0000 (11:20 -0000)
0000042: add subversion (svn) support to buildroot

This patch adds support for subversion to checkout files, much like how CVS
already works. It uses 'SVN' macro in makefiles.

Config.in
package/Makefile.in

index 2b335e68b4a42981a26998c33ee1bf5f24067b86..34ab2359a9398839e417563fb6e0f54546862553 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -76,6 +76,10 @@ config BR2_WGET
        string "Wget command"
        default "wget --passive-ftp -nd"
 
+config BR2_SVN
+        string
+        default "Subversion (svn) checkout command"
+
 config BR2_TAR_VERBOSITY
        bool "Tar verbose"
        default n
index a59ab973fbd44b22ad0afcaa3ecaa2714689fa3a..2fda89fc72a8d5385e0da1e5c4aaebac6e9d9a3c 100644 (file)
@@ -6,6 +6,10 @@ ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
 #"
 WGET:=$(strip $(subst ",, $(BR2_WGET)))
 #"
+SVN:=$(strip $(subst ",, $(BR2_SVN)))
+#"
+
+
 
 ifneq ($(BR2_LARGEFILE),y)
 DISABLE_LARGEFILE= --disable-largefile