dmraid: install init script unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:42 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:19:29 +0000 (00:19 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dmraid/dmraid.mk

index 024b9b5e0d0c69b5212ec0a06cb9eed70ad11e37..a6ed57f3646a00f229837730924259f90fc098dd 100644 (file)
@@ -18,9 +18,8 @@ DMRAID_LICENSE_FILES = $(DMRAID_SUBDIR)/LICENSE_GPL $(DMRAID_SUBDIR)/LICENSE
 DMRAID_DEPENDENCIES = lvm2
 
 define DMRAID_INSTALL_INIT_SYSV
-       [ -f $(TARGET_DIR)/etc/init.d/S20dmraid ] || \
-               $(INSTALL) -D -m 0755 package/dmraid/S20dmraid \
-                       $(TARGET_DIR)/etc/init.d/S20dmraid
+       $(INSTALL) -D -m 0755 package/dmraid/S20dmraid \
+               $(TARGET_DIR)/etc/init.d/S20dmraid
 endef
 
 $(eval $(autotools-package))