libcurl: re-enable on non-MMU platforms
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 14 Feb 2013 03:50:18 +0000 (03:50 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Feb 2013 22:02:01 +0000 (23:02 +0100)
In 9229b82d6326ea425a258b91a9f0157ef6b223b7 ('libcurl: needs MMU'),
the libcurl package was disabled on non-MMU systems, due to the usage
of the fork() function in the library.

However, a deeper inspection reveals that fork() is only used in the
implementation of NTLM, an obscure, undocumented, Microsoft specific
authentication method that apparently isn't common anymore. See
http://curl.haxx.se/docs/manpage.html#--ntlm.

Therefore, this commit re-enables libcurl on non-MMU systems by
explicitly disabling the NTLM support. If someone ever needs NTLM
support in Buildroot's libcurl package, it will always be time to add
a libcurl sub-option to enable it.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libcurl/Config.in
package/libcurl/libcurl.mk

index 10ee0e415d9dc71356f151e06be49bb9e3086915..1d6d08e68017b21f6ba4910d18b5428a04c30e39 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_LIBCURL
        bool "libcurl"
-       depends on BR2_USE_MMU # Uses fork()
        help
          cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet,
          and Dict servers, using any of the supported protocols.
index 38ca854b2dfb3478c9cad2de717c4147f70e9617..a631953af0aad4c2ae2bd38330fb119a220ebeec 100644 (file)
@@ -10,7 +10,13 @@ LIBCURL_SITE = http://curl.haxx.se/download
 LIBCURL_LICENSE = ICS
 LIBCURL_LICENSE_FILES = COPYING
 LIBCURL_INSTALL_STAGING = YES
-LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols
+
+# We disable NTLM support because it uses fork(), which doesn't work
+# on non-MMU platforms. Moreover, this authentication method is
+# probably almost never used. See
+# http://curl.haxx.se/docs/manpage.html#--ntlm.
+LIBCURL_CONF_OPT = --disable-verbose --disable-manual \
+       --enable-hidden-symbols --disable-ntlm-wb
 LIBCURL_CONFIG_SCRIPTS = curl-config
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)