uclibc: add option to specify config fragments
authorFloris Bos <bos@je-eigen-domein.nl>
Tue, 28 Apr 2015 14:34:34 +0000 (16:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 May 2015 21:50:41 +0000 (23:50 +0200)
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/Config.in
package/uclibc/uclibc.mk

index b5525e505e9a8ded8a58decc42509df3844c0f4e..dd23853568c49386f1afe29527ddca70c6fb53a2 100644 (file)
@@ -86,6 +86,12 @@ config BR2_UCLIBC_CONFIG
          See also docs/README in this package.
          If unsure, use the default.
 
+config BR2_UCLIBC_CONFIG_FRAGMENT_FILES
+       string "Additional uClibc configuration fragment files"
+       help
+         A space-separated list of configuration fragment files,
+         that will be merged to the main uClibc configuration file.
+
 config BR2_TOOLCHAIN_BUILDROOT_INET_RPC
        bool "Enable RPC support"
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
index ce9b2b49d6c3614131aafeabb07ed9d29c6583b3..b9dce7e2ddc29c8de79c7c27a115e13763c10b3b 100644 (file)
@@ -42,6 +42,7 @@ UCLIBC_CONFIG_FILE = $(call qstrip,$(BR2_UCLIBC_CONFIG))
 endif
 
 UCLIBC_KCONFIG_FILE = $(UCLIBC_CONFIG_FILE)
+UCLIBC_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_UCLIBC_CONFIG_FRAGMENT_FILES))
 
 UCLIBC_KCONFIG_OPTS = \
        $(UCLIBC_MAKE_FLAGS) \