projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
49e3aba
)
Makefile: support relative paths for out of tree builds
author
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 16 Sep 2008 20:53:45 +0000
(20:53 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 16 Sep 2008 20:53:45 +0000
(20:53 -0000)
And complain if the output directory cannot be created.
project/Makefile.in
patch
|
blob
|
history
diff --git
a/project/Makefile.in
b/project/Makefile.in
index 034b1fa6c9d89d0da076711349c13dd52c3167ee..6aa1d43e92ad415c3bf21303e579d6ddc083e2e9 100644
(file)
--- a/
project/Makefile.in
+++ b/
project/Makefile.in
@@
-30,7
+30,8
@@
TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
BASE_DIR:=$(shell pwd)
ifdef O
ifeq ("$(origin O)", "command line")
-BASE_DIR := $(O)
+BASE_DIR := $(shell mkdir -p $(O) && cd $(O) && pwd)
+$(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
endif
endif