uclibc: enable debug build option
authorPeter Seiderer <ps.report@gmx.net>
Sun, 15 May 2016 20:50:25 +0000 (22:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 May 2016 20:32:31 +0000 (22:32 +0200)
Set uClibc DODEBUG in case BR2_ENABLE_DEBUG is set.

Setting DODEBUG was removed with commit 70b7079d3797304fe3c9ba2941d3f446af3cea79
in Dec. 2013 because of build failures with the old uClibc (now replaced
with uClibc-ng), no build failure with raspberrypi3_defconfig and
BR2_ENABLE_DEBUG enabled.

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index b8ccee2cc8c922428f7808dbe5b79f7fc932313f..67826824f52ccccee1ca96a8ffb77c09aff5be92 100644 (file)
@@ -181,6 +181,15 @@ define UCLIBC_X86_TYPE_CONFIG
 endef
 endif
 
+#
+# Debug
+#
+ifeq ($(BR2_ENABLE_DEBUG),y)
+define UCLIBC_DEBUG_CONFIG
+       $(call KCONFIG_ENABLE_OPT,DODEBUG,$(@D)/.config)
+endef
+endif
+
 #
 # Endianness
 #
@@ -394,6 +403,7 @@ define UCLIBC_KCONFIG_FIXUP_CMDS
        $(UCLIBC_SPARC_TYPE_CONFIG)
        $(UCLIBC_POWERPC_TYPE_CONFIG)
        $(UCLIBC_X86_TYPE_CONFIG)
+       $(UCLIBC_DEBUG_CONFIG)
        $(UCLIBC_ENDIAN_CONFIG)
        $(UCLIBC_LARGEFILE_CONFIG)
        $(UCLIBC_IPV6_CONFIG)