package/mpv: bump version to 0.33.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 12 Jan 2021 06:52:24 +0000 (07:52 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 16 Jan 2021 21:03:19 +0000 (22:03 +0100)
rsound support was removed:
https://github.com/mpv-player/mpv/commit/4583bd8cc7bf538bce424983d49729c934d13a53

libass is now mandatory:
https://github.com/mpv-player/mpv/commit/0b9ed9c2744ada1eefc1f254c5f3ade6c626ed72
Propagate new dependencies to tovid.

libsmbclient support was removed:
https://github.com/mpv-player/mpv/commit/3b8b7cb9d481828953f105f92bacc07a3cb2f332

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/Config.in
package/mpv/mpv.hash
package/mpv/mpv.mk
package/tovid/Config.in

index 697ad57ba6015f0170ecbc19ec40d9944c9a1050..fd3a3f787dc7e6418884d3a14105efc0ba7cc562 100644 (file)
@@ -1,12 +1,15 @@
 config BR2_PACKAGE_MPV
        bool "mpv"
+       depends on BR2_INSTALL_LIBSTDCPP # libass
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # libass
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
-       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # libass
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_FFMPEG
        select BR2_PACKAGE_FFMPEG_SWSCALE
+       select BR2_PACKAGE_LIBASS
        select BR2_PACKAGE_ZLIB
        select BR2_PACKAGE_WAYLAND_PROTOCOLS if BR2_PACKAGE_WAYLAND
        # Select xkbcommon for wayland to avoid being mysterious
@@ -23,8 +26,10 @@ config BR2_PACKAGE_MPV
 
          https://mpv.io/
 
-comment "mpv needs a toolchain w/ threads, gcc >= 4.5"
+comment "mpv needs a toolchain w/ C++, threads, gcc >= 4.8"
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_TOOLCHAIN_HAS_THREADS || \
-               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
+               !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
index 37db771356563c078dff4ba1198d4b72030cbaee..548a0f0159e0b810cb84d182aeabe1e6d23d7687 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256  9163f64832226d22e24bbc4874ebd6ac02372cd717bef15c28a0aa858c5fe592  mpv-0.32.0.tar.gz
+sha256  f1b9baf5dc2eeaf376597c28a6281facf6ed98ff3d567e3955c95bf2459520b4  mpv-0.33.0.tar.gz
 sha256  a99d7b0625a0566271aad6de694e52eafd566db024f9516720d526c680d3ee30  LICENSE.GPL
index a7c9f7d74a4d321cf35e25b3b223d8ff9bf56692..18f307d186b70eb19dbcb5dacddc62827877b2c5 100644 (file)
@@ -4,10 +4,10 @@
 #
 ################################################################################
 
-MPV_VERSION = 0.32.0
+MPV_VERSION = 0.33.0
 MPV_SITE = $(call github,mpv-player,mpv,v$(MPV_VERSION))
 MPV_DEPENDENCIES = \
-       host-pkgconf ffmpeg zlib \
+       host-pkgconf ffmpeg libass zlib \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 MPV_LICENSE = GPL-2.0+
 MPV_LICENSE_FILES = LICENSE.GPL
@@ -23,7 +23,6 @@ MPV_CONF_OPTS = \
        --disable-coreaudio \
        --disable-cuda-hwaccel \
        --disable-opensles \
-       --disable-rsound \
        --disable-rubberband \
        --disable-uchardet \
        --disable-vapoursynth
@@ -77,14 +76,6 @@ else
 MPV_CONF_OPTS += --disable-libarchive
 endif
 
-# libass subtitle support
-ifeq ($(BR2_PACKAGE_LIBASS),y)
-MPV_CONF_OPTS += --enable-libass
-MPV_DEPENDENCIES += libass
-else
-MPV_CONF_OPTS += --disable-libass
-endif
-
 # bluray support
 ifeq ($(BR2_PACKAGE_LIBBLURAY),y)
 MPV_CONF_OPTS += --enable-libbluray
@@ -150,14 +141,6 @@ else
 MPV_CONF_OPTS += --disable-pulse
 endif
 
-# samba support
-ifeq ($(BR2_PACKAGE_SAMBA4),y)
-MPV_CONF_OPTS += --enable-libsmbclient
-MPV_DEPENDENCIES += samba4
-else
-MPV_CONF_OPTS += --disable-libsmbclient
-endif
-
 # SDL support
 # Sdl2 requires 64-bit sync intrinsics
 ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_8)$(BR2_PACKAGE_SDL2),yy)
index f4ddcfa4a08f87eddb79b2d587976ce3f0812761..a0a6af712f75c6181530cee9b7d2c5b653c31ead 100644 (file)
@@ -6,8 +6,9 @@ config BR2_PACKAGE_TOVID
        depends on BR2_USE_WCHAR
        depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
-       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5 # mpv
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # mpv
        depends on BR2_TOOLCHAIN_HAS_ATOMIC # mpv
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # mpv
        depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC # mpv
        # The below dependencies are runtime dependencies only
        select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # procps_ng
@@ -28,12 +29,13 @@ config BR2_PACKAGE_TOVID
 
          http://tovid.wikia.com/wiki/Installing_tovid
 
-comment "tovid needs a toolchain w/ threads, C++, wchar, gcc >= 4.5"
+comment "tovid needs a toolchain w/ threads, C++, wchar, gcc >= 4.8"
        depends on BR2_USE_MMU
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_TOOLCHAIN_HAS_THREADS \
-               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_5 \
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
                || !BR2_INSTALL_LIBSTDCPP \
                || !BR2_USE_WCHAR
        depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC
@@ -42,6 +44,7 @@ comment "tovid depends on python or python3"
        depends on !BR2_PACKAGE_PYTHON && !BR2_PACKAGE_PYTHON3
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_TOOLCHAIN_HAS_THREADS || \
-               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
        depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC