linux: drop the option to use the same version as that of the headers
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 5 Feb 2016 23:06:17 +0000 (00:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 6 Feb 2016 09:58:24 +0000 (10:58 +0100)
It is no longer meaningful, now that we have the option to use the
kernel version for the linux headers, as it is more logical and more
versatile.

Add it to legacy.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
linux/Config.in
linux/linux.mk

index 793b11619c7633b806b6b4a6c7426cd8f8bfe3fb..b38cf9079a422a619faf12da61139eadc113d133 100644 (file)
@@ -145,6 +145,16 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.02"
 
+config BR2_LINUX_KERNEL_SAME_AS_HEADERS
+       bool "using the linux headers version for the kernel has been removed"
+       select BR2_LEGACY
+       help
+         The option to use the version of the kernel headers for the
+         kernel to build has been removed.
+
+         There is now the converse, better-suited and more versatile
+         option to use the kernel version for the linux headers.
+
 config BR2_PACKAGE_CUPS_PDFTOPS
        bool "Pdftops support has been removed from Cups"
        select BR2_LEGACY
index 89711928734b4c50e9f469ff586803ab1ca2c189..4d972e1447582df275cbfe49e2883446fa028b68 100644 (file)
@@ -29,18 +29,6 @@ choice
 config BR2_LINUX_KERNEL_LATEST_VERSION
        bool "4.4.1"
 
-config BR2_LINUX_KERNEL_SAME_AS_HEADERS
-       bool "Same as toolchain kernel headers"
-       depends on !BR2_KERNEL_HEADERS_AS_KERNEL
-       depends on BR2_TOOLCHAIN_BUILDROOT
-       help
-         This option will re-use the same kernel sources as the one
-         that have been used for the kernel headers of the
-         cross-compiling toolchain. Having the same version for the
-         kernel running on the system and for the kernel headers is
-         not a requirement, but using the same version allows to
-         download only one tarball of the kernel sources.
-
 config BR2_LINUX_KERNEL_CUSTOM_VERSION
        bool "Custom version"
        help
@@ -117,7 +105,6 @@ config BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH
 config BR2_LINUX_KERNEL_VERSION
        string
        default "4.4.1" if BR2_LINUX_KERNEL_LATEST_VERSION
-       default BR2_DEFAULT_KERNEL_HEADERS if BR2_LINUX_KERNEL_SAME_AS_HEADERS
        default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE \
                if BR2_LINUX_KERNEL_CUSTOM_VERSION
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
index c9986cd8a9fbcf0d6493767ee0e9ca0d14188570..578fea1a589d59ebd518b904c15a132101f8dce2 100644 (file)
@@ -28,9 +28,6 @@ LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
 ifeq ($(BR2_LINUX_KERNEL_CUSTOM_VERSION),y)
 BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
 endif
-ifeq ($(BR2_LINUX_KERNEL_SAME_AS_HEADERS)$(BR2_KERNEL_HEADERS_VERSION),yy)
-BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
-endif
 # In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
 # to use the $(word) function. We support versions such as 4.0, 3.1,
 # 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.