Fixup ncurses terminfo-dir. Fixup the ncurses-headers
authorEric Andersen <andersen@codepoet.org>
Wed, 8 Jan 2003 18:17:28 +0000 (18:17 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 8 Jan 2003 18:17:28 +0000 (18:17 -0000)
zlib-headers openssl-headers targets.  Modularize the
enable-multilib settings
 -Erik

make/gcc_target.mk
make/ncurses.mk
make/openssl.mk
make/uclibc_toolchain.mk
make/zlib.mk

index 0e466bdc53e5d9d6679598af10413f0ee9915fa4..f78e0bfc71f9bcaf169d4e892176b65e3cb5773d 100644 (file)
 #
 #############################################################
 GNU_TARGET_NAME:=$(ARCH)-linux
+TARGET_LANGUAGES:=c,c++
 MAKE:=make
 
+# If you want multilib enabled, enable this...
+#MULTILIB:=--enable-multilib
+
 #############################################################
 #
 # Where we can find things....
@@ -51,7 +55,6 @@ $(BINUTILS_DIR2)/.configured:
        (cd $(TARGET_DIR)/usr/$(GNU_TARGET_NAME); ln -fs ../include sys-include)
        (cd $(BINUTILS_DIR2); PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CROSS)gcc \
                $(BINUTILS_DIR)/configure \
-               --target=$(GNU_TARGET_NAME) \
                --prefix=/usr \
                --exec-prefix=/usr \
                --bindir=/usr/bin \
@@ -64,7 +67,7 @@ $(BINUTILS_DIR2)/.configured:
                --mandir=/usr/man \
                --infodir=/usr/info \
                --with-gxx-include-dir=/usr/include/c++ \
-               --disable-shared --enable-multilib \
+               --disable-shared $(MULTILIB) \
                --enable-targets=$(GNU_TARGET_NAME) );
        touch $(BINUTILS_DIR2)/.configured
 
@@ -77,7 +80,7 @@ $(TARGET_DIR)/usr/bin/ld: $(BINUTILS_DIR2)/binutils/objdump
            exec_prefix=$(TARGET_DIR)/usr \
            bindir=$(TARGET_DIR)/usr/bin \
            sbindir=$(TARGET_DIR)/usr/sbin \
-           libexecdir=$(TARGET_DIR)/usr/libexec \
+           libexecdir=$(TARGET_DIR)/usr/lib \
            datadir=$(TARGET_DIR)/usr/share \
            sysconfdir=$(TARGET_DIR)/etc \
            sharedstatedir=$(TARGET_DIR)/usr/com \
@@ -161,14 +164,13 @@ $(GCC_BUILD_DIR3)/.gcc_build_hacks:
                $(STAGING_DIR)/usr/include,;" $(GCC_DIR)/gcc/Makefile.in;
        perl -i -p -e "s,^#define.*STANDARD_INCLUDE_DIR.*,#define STANDARD_INCLUDE_DIR \
                \"/usr/include\",;" $(GCC_DIR)/gcc/cppdefault.h;
+       touch $(GCC_BUILD_DIR3)/.gcc_build_hacks
 
 $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.gcc_build_hacks
        mkdir -p $(GCC_BUILD_DIR3)
        (cd $(GCC_BUILD_DIR3); PATH=$(STAGING_DIR)/bin:$$PATH AR=$(TARGET_CROSS)ar \
                RANLIB=$(TARGET_CROSS)ranlib LD=$(TARGET_CROSS)ld CC=$(TARGET_CROSS)gcc \
                $(GCC_DIR)/configure \
-               --host=$(GNU_TARGET_NAME) \
-               --target=$(GNU_TARGET_NAME) \
                --prefix=/usr \
                --exec-prefix=/usr \
                --bindir=/usr/bin \
@@ -179,9 +181,9 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.gcc_build_hacks
                --localstatedir=/var \
                --mandir=/usr/man \
                --infodir=/usr/info \
-               --disable-shared --enable-multilib \
+               --disable-shared $(MULTILIB) \
                --enable-target-optspace --disable-nls --with-gnu-ld \
-               --enable-languages=c,c++ --disable-__cxa_atexit );
+               --enable-languages=$(TARGET_LANGUAGES) --disable-__cxa_atexit );
        touch $(GCC_BUILD_DIR3)/.configured
 
 $(GCC_BUILD_DIR3)/.compiled: $(GCC_BUILD_DIR3)/.configured
@@ -194,7 +196,7 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
            exec_prefix=$(TARGET_DIR)/usr \
            bindir=$(TARGET_DIR)/usr/bin \
            sbindir=$(TARGET_DIR)/usr/sbin \
-           libexecdir=$(TARGET_DIR)/usr/libexec \
+           libexecdir=$(TARGET_DIR)/usr/lib \
            datadir=$(TARGET_DIR)/usr/share \
            sysconfdir=$(TARGET_DIR)/etc \
            sharedstatedir=$(TARGET_DIR)/usr/com \
index fc9dc7bd3042fa3c9653d5bf4edc167f53526e94..ea26a8bd5746613b4b4d4aeeef4b931902775d3c 100644 (file)
@@ -5,7 +5,7 @@
 #
 #############################################################
 # Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.12 2003/01/08 02:37:03 andersen Exp $
+# $Id: ncurses.mk,v 1.13 2003/01/08 18:17:28 andersen Exp $
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU Library General Public License as
@@ -38,13 +38,25 @@ $(NCURSES_DIR)/.dist: $(DL_DIR)/$(NCURSES_SOURCE)
        touch  $(NCURSES_DIR)/.dist
 
 $(NCURSES_DIR)/.configured: $(NCURSES_DIR)/.dist
-       (cd $(NCURSES_DIR); rm -rf config.cache; \
-           BUILD_CC=$(HOSTCC) HOSTCC=$(HOSTCC) CC=$(TARGET_CC1) \
-           ./configure --target=$(GNU_TARGET_NAME) --prefix=$(STAGING_DIR) \
-           --with-shared --without-cxx --without-cxx-binding --without-ada \
-           --without-progs --exec_prefix=$(STAGING_DIR)/usr/bin \
-           --libdir=$(STAGING_DIR)/lib --includedir=$(STAGING_DIR)/include \
-           --disable-nls);
+       (cd $(NCURSES_DIR); rm -rf config.cache; PATH=$(STAGING_DIR)/bin:$$PATH \
+               BUILD_CC=$(HOSTCC) HOSTCC=$(HOSTCC) CC=$(TARGET_CC1) \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               --with-terminfo-dirs=/usr/share/terminfo \
+               --with-default-terminfo-dir=/usr/share/terminfo \
+               --libdir=$(STAGING_DIR)/lib \
+               --includedir=$(STAGING_DIR)/include \
+               --with-shared --without-cxx --without-cxx-binding --without-ada \
+               --without-progs --disable-nls);
        touch  $(NCURSES_DIR)/.configured
 
 $(NCURSES_DIR)/lib/libncurses.so: $(NCURSES_DIR)/.configured
@@ -52,16 +64,32 @@ $(NCURSES_DIR)/lib/libncurses.so: $(NCURSES_DIR)/.configured
                DESTDIR=$(STAGING_DIR) -C $(NCURSES_DIR)
 
 $(STAGING_DIR)/lib/libncurses.so: $(NCURSES_DIR)/lib/libncurses.so
-       cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(STAGING_DIR)/lib/
-       cp -dpf $(NCURSES_DIR)/include/curses.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/eti.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/form.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/menu.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/panel.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/term.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/termcap.h $(STAGING_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/unctrl.h $(STAGING_DIR)/include/
-       (cd $(STAGING_DIR)/include; ln -fs curses.h ncurses.h)
+       PATH=$(STAGING_DIR)/bin:$$PATH BUILD_CC=$(HOSTCC) \
+           HOSTCC=$(HOSTCC) CC=$(TARGET_CC1) $(MAKE) \
+           prefix=$(STAGING_DIR) \
+           exec_prefix=$(STAGING_DIR) \
+           bindir=$(STAGING_DIR)/bin \
+           sbindir=$(STAGING_DIR)/sbin \
+           libexecdir=$(STAGING_DIR)/lib \
+           datadir=$(STAGING_DIR)/usr/share \
+           sysconfdir=$(STAGING_DIR)/etc \
+           localstatedir=$(STAGING_DIR)/var \
+           libdir=$(STAGING_DIR)/lib \
+           infodir=$(STAGING_DIR)/info \
+           mandir=$(STAGING_DIR)/man \
+           includedir=$(STAGING_DIR)/include \
+           gxx_include_dir=$(STAGING_DIR)/include/c++ \
+           -C $(NCURSES_DIR) install;
+       #cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(STAGING_DIR)/lib/
+       #cp -dpf $(NCURSES_DIR)/include/curses.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/eti.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/form.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/menu.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/panel.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/term.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/termcap.h $(STAGING_DIR)/include/
+       #cp -dpf $(NCURSES_DIR)/include/unctrl.h $(STAGING_DIR)/include/
+       #(cd $(STAGING_DIR)/include; ln -fs curses.h ncurses.h)
 
 $(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
        cp -dpf $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
@@ -72,18 +100,17 @@ $(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
                        tar -C $(TARGET_DIR)/usr/share/ -xf - ; \
        done
 
-$(TARGET_DIR)/usr/include/curses.h: $(TARGET_DIR)/lib/libncurses.so
-       cp -dpf $(NCURSES_DIR)/include/curses.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/eti.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/form.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/menu.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/panel.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/term.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/termcap.h $(TARGET_DIR)/include/
-       cp -dpf $(NCURSES_DIR)/include/unctrl.h $(TARGET_DIR)/include/
-       (cd $(TARGET_DIR)/include; ln -fs curses.h ncurses.h)
+$(TARGET_DIR)/usr/include/ncurses.h: $(TARGET_DIR)/lib/libncurses.so
+       cp -dpf $(NCURSES_DIR)/include/curses.h $(TARGET_DIR)/usr/include/ncurses.h
+       cp -dpf $(NCURSES_DIR)/include/term.h $(TARGET_DIR)/usr/include/
+       cp -dpf $(NCURSES_DIR)/include/termcap.h $(TARGET_DIR)/usr/include/
+       cp -dpf $(NCURSES_DIR)/lib/libncurses.a $(TARGET_DIR)/usr/lib/
+       (cd $(TARGET_DIR)/usr/lib; ln -fs libncurses.a libcurses.a)
+       (cd $(TARGET_DIR)/usr/lib; ln -fs libncurses.a libtermcap.a)
+       (cd $(TARGET_DIR)/usr/include; ln -fs ncurses.h curses.h)
+       touch -c $(TARGET_DIR)/usr/include/ncurses.h
 
-ncurses-headers: $(TARGET_DIR)/usr/include/curses.h
+ncurses-headers: $(TARGET_DIR)/usr/include/ncurses.h
 
 ncurses-clean: 
        rm -f $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/libncurses.so*
index 3f1ac988d1af480bc5b34fdd9b996094ebcb3370..15948c06662f113fc97682714a00bf17d422512c 100644 (file)
@@ -42,6 +42,14 @@ $(TARGET_DIR)/lib/libcrypto.so.0: $(STAGING_DIR)/lib/libcrypto.so.0
        cp -fa $(STAGING_DIR)/lib/libssl.so* $(TARGET_DIR)/lib/
        #cp -fa $(STAGING_DIR)/bin/openssl  $(TARGET_DIR)/bin/
 
+$(TARGET_DIR)/usr/include/openssl/crypto.h: $(TARGET_DIR)/lib/libcrypto.so.0
+       cp -a $(STAGING_DIR)/include/openssl $(TARGET_DIR)/usr/include/
+       cp -dpf $(STAGING_DIR)/lib/libssl.a $(TARGET_DIR)/usr/lib/
+       cp -dpf $(STAGING_DIR)/lib/libcrypto.a $(TARGET_DIR)/usr/lib/
+       touch -c $(TARGET_DIR)/usr/include/openssl/crypto.h
+
+openssl-headers: $(TARGET_DIR)/usr/include/openssl/crypto.h
+
 openssl-clean: 
        rm -f $(STAGING_DIR)/bin/openssl  $(TARGET_DIR)/bin/openssl
        rm -f $(STAGING_DIR)/lib/libcrypto.so* $(TARGET_DIR)/lib/libcrypto.so*
index afb61633af37c41c102534ba8e8c440682510889..7e37cf387a9a3943ce4187cced06d4622fac27e4 100644 (file)
@@ -28,6 +28,9 @@ GNU_TARGET_NAME:=$(ARCH)-linux
 TARGET_LANGUAGES:=c,c++
 MAKE=make
 
+# If you want multilib enabled, enable this...
+#MULTILIB:=--enable-multilib
+
 #############################################################
 #
 # Where we can find things....
@@ -133,7 +136,7 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
                --datadir=$(STAGING_DIR)/share --includedir=$(STAGING_DIR)/include \
                --libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
                --mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
-               --enable-targets=$(GNU_TARGET_NAME) --enable-multilib \
+               --enable-targets=$(GNU_TARGET_NAME) $(MULTILIB) \
                --program-prefix=$(ARCH)-uclibc-);
        touch $(BINUTILS_DIR1)/.configured
 
@@ -222,7 +225,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.gcc_build_hacks
                --libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
                --mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
                --with-local-prefix=$(STAGING_DIR)/usr/local \
-               --oldincludedir=$(STAGING_DIR)/usr/include --enable-multilib \
+               --oldincludedir=$(STAGING_DIR)/usr/include $(MULTILIB) \
                --enable-target-optspace --disable-nls --with-gnu-ld \
                --disable-shared --enable-languages=c --disable-__cxa_atexit \
                --program-prefix=$(ARCH)-uclibc-);
@@ -365,7 +368,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.g++_build_hacks
                --libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
                --mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
                --with-local-prefix=$(STAGING_DIR)/usr/local \
-               --oldincludedir=$(STAGING_DIR)/usr/include --enable-multilib \
+               --oldincludedir=$(STAGING_DIR)/usr/include $(MULTILIB) \
                --enable-target-optspace --disable-nls --with-gnu-ld \
                --disable-shared --enable-languages=$(TARGET_LANGUAGES) --disable-__cxa_atexit \
                --program-prefix=$(ARCH)-uclibc-);
index ef28bde18035edff40c68070fc44497fdf39a8d3..ee10e70511d0486154919f0e09515d5fb8e9ba9a 100644 (file)
@@ -41,6 +41,14 @@ $(TARGET_DIR)/lib/libz.so.1.1.4: $(STAGING_DIR)/lib/libz.so.1.1.4
        -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libz.so*
        touch -c $(TARGET_DIR)/lib/libz.so.1.1.4
 
+$(TARGET_DIR)/usr/include/zlib.h: $(TARGET_DIR)/lib/libz.so.1.1.4
+       cp -a $(STAGING_DIR)/include/zlib.h $(TARGET_DIR)/usr/include/
+       cp -a $(STAGING_DIR)/include/zconf.h $(TARGET_DIR)/usr/include/
+       cp -a $(STAGING_DIR)/lib/libz.a $(TARGET_DIR)/usr/lib/
+       touch -c $(TARGET_DIR)/usr/include/zlib.h
+
+zlib-headers: $(TARGET_DIR)/usr/include/zlib.h
+
 zlib: uclibc $(TARGET_DIR)/lib/libz.so.1.1.4
 
 zlib-clean: