SDL_net: add new package SDL_net
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 24 Sep 2008 12:06:59 +0000 (12:06 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 24 Sep 2008 12:06:59 +0000 (12:06 -0000)
This patch adds a new package SDL_net. SDL_net is a small, low-level,
cross-platform network library, that can be used with the Simple DirectMedia
Layer library (SDL).

http://www.libsdl.org/projects/SDL_net/

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/Config.in
package/sdl_net/Config.in [new file with mode: 0644]
package/sdl_net/sdl_net.mk [new file with mode: 0644]

index e55fe16f376d83f1efaca2431bb1666c4091c257..c845d929520e04c9b2db44144525a8e74194b022 100644 (file)
@@ -320,6 +320,7 @@ source "package/pixman/Config.in"
 source "package/sdl/Config.in"
 source "package/sdl_image/Config.in"
 source "package/sdl_mixer/Config.in"
+source "package/sdl_net/Config.in"
 source "package/sdl_ttf/Config.in"
 source "package/tiff/Config.in"
 
diff --git a/package/sdl_net/Config.in b/package/sdl_net/Config.in
new file mode 100644 (file)
index 0000000..2001d23
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_SDL_NET
+       bool "SDL_net"
+       depends on BR2_PACKAGE_SDL
+       help
+         SDL_net is a small, low-level, cross-platform network library, that
+         can be used with the Simple DirectMedia Layer library (SDL).
+
+         http://www.libsdl.org/projects/SDL_net/
diff --git a/package/sdl_net/sdl_net.mk b/package/sdl_net/sdl_net.mk
new file mode 100644 (file)
index 0000000..144d02d
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# SDL_net: network addon for SDL
+#
+#############################################################
+SDL_NET_VERSION:=1.2.7
+SDL_NET_SITE:=http://www.libsdl.org/projects/SDL_net/release
+
+SDL_NET_CONF_OPT = --localstatedir=/var \
+               --with-sdl-prefix=$(STAGING_DIR)/usr \
+               --with-sdl-exec-prefix=$(STAGING_DIR)/usr
+
+SDL_NET_INSTALL_STAGING = YES
+SDL_NET_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install
+
+SDL_NET_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+
+SDL_NET_DEPENDENCIES = sdl
+
+$(eval $(call AUTOTARGETS,package,SDL_net))