bluez-alsa: bump to version 1.3.0
authorJörg Krause <joerg.krause@embedded.rocks>
Fri, 20 Jul 2018 07:04:18 +0000 (09:04 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 20 Jul 2018 07:35:29 +0000 (09:35 +0200)
Add optional build of rfcomm which requires readline.

Update license hash as authorship has been updated in the license file.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bluez-alsa/Config.in
package/bluez-alsa/bluez-alsa.hash
package/bluez-alsa/bluez-alsa.mk

index 1753da48f90647cf73c0e1559f8e6079d466ba33..e52933f07c7c39abecb6256399dcce89d1439c8b 100644 (file)
@@ -26,6 +26,12 @@ config BR2_PACKAGE_BLUEZ_ALSA_HCITOP
        help
          Enable top-like monitoring tool for HCI.
 
+config BR2_PACKAGE_BLUEZ_ALSA_RFCOMM
+       bool "rfcomm"
+       select BR2_PACKAGE_READLINE
+       help
+         Simple tool for sending RFCOMM commands.
+
 endif
 
 comment "bluez-alsa needs a toolchain w/ wchar, NPTL, headers >= 3.4, dynamic library"
index b96c37cc468b0407969bef2afcef4d1e65c2241c..5036f82eaa96f021fa08e90e548061ee323bbcce 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated:
-sha256  dfa48e991a6bbb194a9161deb949371155150dabd5cfc1453a8df754b7cbdc84  bluez-alsa-9045edb436ea755f395a2e09e4525b5defad286a.tar.gz
-sha256  c90a0081b0526834f700d084e48819b18d11453ecb030c9b7de0d2cc3e3711a5  LICENSE.txt
+sha256  20005c4a153346ea7941973e9b7bd0b228417351f2e8ce88d1c02cc62bca188e  bluez-alsa-v1.3.0.tar.gz
+sha256  4738489ada14818fe4c53ce86223d7b2f4c1f57cb1f93d62c973c94a89080e83  LICENSE.txt
index 3ba237a6b782d9e18cbae0c5f3d79939b40b98d2..fdf7e464a79cf438b659a420346bc06c4c71c3b9 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BLUEZ_ALSA_VERSION = 9045edb436ea755f395a2e09e4525b5defad286a
+BLUEZ_ALSA_VERSION = v1.3.0
 BLUEZ_ALSA_SITE = $(call github,Arkq,bluez-alsa,$(BLUEZ_ALSA_VERSION))
 BLUEZ_ALSA_LICENSE = MIT
 BLUEZ_ALSA_LICENSE_FILES = LICENSE.txt
@@ -40,4 +40,11 @@ else
 BLUEZ_ALSA_CONF_OPTS += --disable-hcitop
 endif
 
+ifeq ($(BR2_PACKAGE_BLUEZ_ALSA_RFCOMM),y)
+BLUEZ_ALSA_DEPENDENCIES += readline
+BLUEZ_ALSA_CONF_OPTS += --enable-rfcomm
+else
+BLUEZ_ALSA_CONF_OPTS += --disable-rfcomm
+endif
+
 $(eval $(autotools-package))