aumix: fix install rule to target to support multiple projects
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 18 Sep 2008 08:42:56 +0000 (08:42 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 18 Sep 2008 08:42:56 +0000 (08:42 -0000)
This patch will let aumix depend on an installed file on the target root file
system instead of touched file.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/audio/aumix/aumix.mk

index d30b3a7be7db5567868e7e9cb5315266acdfed20..4ee7b0a0a4a28b02268834c48988837c6e35116d 100644 (file)
@@ -41,11 +41,10 @@ $(AUMIX_DIR)/.configured: $(AUMIX_DIR)/.unpacked
 $(AUMIX_DIR)/src/aumix: $(AUMIX_DIR)/.configured
        $(MAKE) CC=$(TARGET_CC) -C $(AUMIX_DIR)
 
-$(AUMIX_DIR)/.installed: $(AUMIX_DIR)/src/aumix
+$(TARGET_DIR)/usr/bin/aumix: $(AUMIX_DIR)/src/aumix
        $(MAKE) -C $(AUMIX_DIR) DESTDIR=$(TARGET_DIR) install
-       touch $@
 
-aumix: uclibc ncurses $(AUMIX_DIR)/.installed
+aumix: uclibc ncurses $(TARGET_DIR)/usr/bin/aumix
 
 aumix-source: $(DL_DIR)/$(AUMIX_SOURCE)