autoconf: add AUTOHEADER variable
authorLionel Landwerlin <llandwerlin@gmail.com>
Fri, 30 Apr 2010 00:24:11 +0000 (02:24 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 07:37:15 +0000 (09:37 +0200)
autoheader is used by autoreconf, therefor we need to give the right
path to this tools for host/target autoreconfiguration.

Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/autoconf/autoconf.mk

index d82c2c5c772075b20b5b7f09b54068dac5b46fed..b7c1fe4d1942de28a754e0d58d6cceecb7c081f6 100644 (file)
@@ -17,7 +17,7 @@ AUTOCONF_CONF_ENV = EMACS="no" ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
 AUTOCONF_DEPENDENCIES = microperl host-m4
 
 HOST_AUTOCONF_CONF_ENV = ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
-                        ac_cv_prog_gnu_m4_gnu=no
+                       ac_cv_prog_gnu_m4_gnu=no
 
 HOST_AUTOCONF_DEPENDENCIES = host-m4 host-libtool
 
@@ -26,4 +26,5 @@ $(eval $(call AUTOTARGETS,package,autoconf,host))
 
 # variables used by other packages
 AUTOCONF:=$(HOST_DIR)/usr/bin/autoconf
-AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" $(HOST_DIR)/usr/bin/autoreconf -v -f -i -I "$(ACLOCAL_DIR)"
+AUTOHEADER:=$(HOST_DIR)/usr/bin/autoheader
+AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOHEADER="$(AUTOHEADER)" $(HOST_DIR)/usr/bin/autoreconf -v -f -i -I "$(ACLOCAL_DIR)"