package/alure: new package
authorRomain Naour <romain.naour@gmail.com>
Sun, 5 Jan 2020 11:31:59 +0000 (12:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jan 2020 20:21:02 +0000 (21:21 +0100)
Use the latest commit since there is no release since 1.2 (8 years ago).

While testing with test-pkg, the last build issue was
due to the gcc 4.8.3 compiler missing C++11 feature:
"std::list.erase(const_iterator pos) not implemented" [1]

arm-none-linux-gnueabi/include/c++/4.8.3/bits/vector.tcc:134:5: note:
no known conversion for argument 1 from '__gnu_cxx::__normal_iterator<const alure::Source*, std::vector<alure::Source> >'
to 'std::vector<alure::Source>::iterator {aka __gnu_cxx::__normal_iterator<alure::Source*, std::vector<alure::Source> >}

https://github.com/kcat/alure/blob/14beed2a86d5a36030e907b21c46614d505f07cd/src/context.cpp#L1357

[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=57158

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/alure/Config.in [new file with mode: 0644]
package/alure/alure.hash [new file with mode: 0644]
package/alure/alure.mk [new file with mode: 0644]

index 80843dd1a113ec85699fd7e17e3529d984e1cd80..d7b14d14b49de26d7b7cb4a40b526abe39d4366f 100644 (file)
@@ -2106,6 +2106,7 @@ F:        package/irssi/
 F:     package/vnstat/
 
 N:     Romain Naour <romain.naour@gmail.com>
+F:     package/alure/
 F:     package/aubio/
 F:     package/binutils/
 F:     package/bullet/
index 873a592d64d1695b85a3370e8cf265c252fc461f..43fcc20d4716e08de6e338f4550254aa7a6873b1 100644 (file)
@@ -1203,6 +1203,7 @@ menu "Libraries"
 
 menu "Audio/Sound"
        source "package/alsa-lib/Config.in"
+       source "package/alure/Config.in"
        source "package/aubio/Config.in"
        source "package/audiofile/Config.in"
        source "package/bcg729/Config.in"
diff --git a/package/alure/Config.in b/package/alure/Config.in
new file mode 100644 (file)
index 0000000..4acd66d
--- /dev/null
@@ -0,0 +1,27 @@
+config BR2_PACKAGE_ALURE
+       bool "alure"
+       depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++11
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # openal
+       depends on BR2_USE_WCHAR # use wchar_t
+       depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # std::shared_future
+       select BR2_PACKAGE_OPENAL
+       help
+         Alure is a C++ 3D audio API. It uses OpenAL for audio
+         rendering, and provides common higher-level features such as
+         file loading and decoding, buffer caching, background
+         streaming, and source management for virtually unlimited
+         sound source handles.
+
+         https://kcat.strangesoft.net/alure.html
+
+comment "alure needs a toolchain w/ C++, gcc >= 4.9, NPTL, wchar"
+       depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
+       depends on !BR2_INSTALL_LIBSTDCPP \
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 \
+               || !BR2_TOOLCHAIN_HAS_THREADS_NPTL || !BR2_USE_WCHAR
+
+comment "alure needs a toolchain not affected by GCC bug 64735"
+       depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
+       depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
diff --git a/package/alure/alure.hash b/package/alure/alure.hash
new file mode 100644 (file)
index 0000000..3387f76
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 9b808e5b5a54d156348221dc86704c7831115047d5238691e6088f8c4814b2ca  alure-14beed2a86d5a36030e907b21c46614d505f07cd.tar.gz
diff --git a/package/alure/alure.mk b/package/alure/alure.mk
new file mode 100644 (file)
index 0000000..efb0c4c
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# alure
+#
+################################################################################
+
+ALURE_VERSION = 14beed2a86d5a36030e907b21c46614d505f07cd
+ALURE_SITE = $(call github,kcat,alure,$(ALURE_VERSION))
+ALURE_LICENSE = Zlib, Public Domain (src/decoders/dr_flac.h)
+ALURE_LICENSE_FILES = LICENSE
+ALURE_INSTALL_STAGING = YES
+
+ALURE_DEPENDENCIES = openal
+
+# Disabling alure examples remove the dependecies on physfs and dump libraries.
+# Enable at least one built-in decoder (wave).
+ALURE_CONF_OPTS = -DALURE_INSTALL=ON \
+       -DALURE_BUILD_EXAMPLES=OFF \
+       -DALURE_ENABLE_FLAC=OFF \
+       -DALURE_ENABLE_MINIMP3=OFF \
+       -DALURE_ENABLE_OPUS=OFF \
+       -DALURE_ENABLE_SNDFILE=OFF \
+       -DALURE_ENABLE_VORBIS=OFF \
+       -DALURE_ENABLE_WAVE=ON
+
+ifeq ($(BR2_STATIC_LIBS),y)
+ALURE_CONF_OPTS += -DALURE_BUILD_SHARED=OFF \
+       -DALURE_BUILD_STATIC=ON
+else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
+ALURE_CONF_OPTS += -DALURE_BUILD_SHARED=ON \
+       -DALURE_BUILD_STATIC=ON
+else
+ALURE_CONF_OPTS += -DALURE_BUILD_SHARED=ON \
+       -DALURE_BUILD_STATIC=OFF
+endif
+
+$(eval $(cmake-package))