package/libstrophe: bump to version 0.10.0
authorMichael Vetter <jubalh@iodoru.org>
Wed, 16 Sep 2020 10:08:30 +0000 (12:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 17 Sep 2020 20:34:46 +0000 (22:34 +0200)
Changes:
  * Coding style has been unified
  * SCRAM-SHA-256 and SCRAM-SHA-512 support
  * c-ares support
  * LibreSSL support
  * Introduced global timed handlers that fire periodically regardless
    of connections status, such a handler can be used to implement
    deferred re-connection
  * examples/register implements XEP-0077
  * Fixed issue with IPv6 on Windows (#153)
  * Improved portability across systems such as Haiku, Windows
  * New API:
    - xmpp_stanza_get_child_by_name_and_ns()
    - xmpp_conn_is_connecting()
    - xmpp_conn_is_connected()
    - xmpp_conn_is_disconnected()
    - xmpp_stanza_new_from_string()
    - xmpp_stanza_add_child_ex()
    - xmpp_stanza_get_context()
    - xmpp_stanza_reply_error()
    - xmpp_global_timed_handler_add()
    - xmpp_global_timed_handler_delete()

Signed-off-by: Michael Vetter <jubalh@iodoru.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libstrophe/libstrophe.hash
package/libstrophe/libstrophe.mk

index 1e46a82bc9011b89dc67386afce7250abef883e0..5f3b098c895d76fe7ed5fbb95f33b56f190cad3d 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated
-sha256 8a3b79f62177ed59c01d4d4108357ff20bd933d53b845ee4e350d304c051a4fe  libstrophe-0.9.3.tar.gz
+sha256 8d804e4c74cea1133203cc95a59a88f700fbdaead076e7959b495d734dd7936d  libstrophe-0.10.0.tar.gz
 sha256 82476f36ffd5e895a176013c0812166ba7b7d99f3d536fc7f5ed2e33e9f74a08  MIT-LICENSE.txt
 sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  GPL-LICENSE.txt
index d5434f50339ad4ad00af176e66b7a5943f303cd4..81fc1b9f970aa74119d99bf3e8c29444543b5594 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBSTROPHE_VERSION = 0.9.3
+LIBSTROPHE_VERSION = 0.10.0
 LIBSTROPHE_SITE = $(call github,strophe,libstrophe,$(LIBSTROPHE_VERSION))
 LIBSTROPHE_DEPENDENCIES = openssl host-pkgconf
 # Doesn't ship configure