package/systemd: Respect BR2_TARGET_GENERIC_GETTY_BAUDRATE
authorCyril Bur <cyrilbur@gmail.com>
Mon, 7 Mar 2016 01:05:09 +0000 (12:05 +1100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 31 Mar 2016 02:02:49 +0000 (04:02 +0200)
Currently systemd getty services ignore baudrates set in buildroot in
favour of a hardcoded 115200. This patch SEDs out that hardcoded value with
what is selected.

Signed-off-by: Cyril Bur <cyrilbur@gmail.com>
Reviewed-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index 75ad961d597a16a72d1604fa3b1eb879e87656f0..8a6aa44315f1bfa997cd7cc74c0555fbd7cc49b2 100644 (file)
@@ -227,6 +227,7 @@ endef
 
 ifneq ($(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT)),)
 # systemd needs getty.service for VTs and serial-getty.service for serial ttys
+# also patch the file to use the correct baud-rate, the default baudrate is 115200 so look for that
 define SYSTEMD_INSTALL_SERVICE_TTY
        if echo $(BR2_TARGET_GENERIC_GETTY_PORT) | egrep -q 'tty[0-9]*$$'; \
        then \
@@ -235,7 +236,11 @@ define SYSTEMD_INSTALL_SERVICE_TTY
                SERVICE="serial-getty"; \
        fi; \
        ln -fs ../../../../lib/systemd/system/$${SERVICE}@.service \
-               $(TARGET_DIR)/etc/systemd/system/getty.target.wants/$${SERVICE}@$(BR2_TARGET_GENERIC_GETTY_PORT).service
+               $(TARGET_DIR)/etc/systemd/system/getty.target.wants/$${SERVICE}@$(BR2_TARGET_GENERIC_GETTY_PORT).service; \
+       if [ $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE)) -gt 0 ] ; \
+       then \
+               $(SED) 's,115200,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE),' $(TARGET_DIR)/lib/systemd/system/$${SERVICE}@.service; \
+       fi
 endef
 endif