projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
61e61ae
)
vsftpd: fix build when libcap is enabled
author
Peter Korsgaard
<jacmet@sunsite.dk>
Mon, 18 Oct 2010 15:36:01 +0000
(17:36 +0200)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Mon, 18 Oct 2010 15:36:01 +0000
(17:36 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/vsftpd/vsftpd.mk
patch
|
blob
|
history
diff --git
a/package/vsftpd/vsftpd.mk
b/package/vsftpd/vsftpd.mk
index c8c68d27bcde236fa70d89c6786c0d3443dc1a72..64a56ccf22e3ed0574910d2194de4a94ea0b12e1 100644
(file)
--- a/
package/vsftpd/vsftpd.mk
+++ b/
package/vsftpd/vsftpd.mk
@@
-19,6
+19,11
@@
VSFTPD_LIBS += -lssl
VSFTPD_POST_CONFIGURE_HOOKS += VSFTPD_ENABLE_SSL
endif
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+VSFTPD_DEPENDENCIES += libcap
+VSFTPD_LIBS += -lcap
+endif
+
define VSFTPD_BUILD_CMDS
$(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" LIBS="$(VSFTPD_LIBS)" -C $(@D)