package/systemd: group all journal-remote tools under a single option
authorMichael Nosthoff <buildroot@heine.tech>
Wed, 14 Oct 2020 15:12:50 +0000 (17:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 14 Oct 2020 18:41:32 +0000 (20:41 +0200)
The -Dremote=true flag enables three tools: systemd-journal-gatewayd,
systemd-journal-remote and systemd-journal-upload.

It is not possible with simple means to install them seperately. So use
the systemd-journal-remote option to enable or disable them all together.

Drop systemd-journal-gatewayd option and add it to legacy.

Fixes: #12301
Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/systemd/Config.in
package/systemd/systemd.mk

index 95c2fb33b3da3c5257e909f3ff66ec3531117cd2..f535b49809a0f9813c31c5f52dcd87c43f5f215c 100644 (file)
@@ -146,6 +146,14 @@ endif
 
 comment "Legacy options removed in 2020.11"
 
+config BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY
+       bool "systemd-journal-gatewayd now in systemd-journal-remote"
+       select BR2_LEGACY
+       select BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE
+       help
+         All system journal remote programs are now enabled using
+         BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE.
+
 config BR2_TARGET_UBOOT_BOOT_SCRIPT
        bool "u-boot script generation was moved"
        select BR2_LEGACY
index 7956370b838cc1f93433b6b5fa382b7862bf0118..ec34478e3d1617fec04f649e49e1aa98d4f58db5 100644 (file)
@@ -141,29 +141,25 @@ config BR2_PACKAGE_SYSTEMD_BOOT_EFI_ARCH
        default "x64"   if BR2_x86_64
        depends on BR2_PACKAGE_SYSTEMD_BOOT
 
-config BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY
-       bool "HTTP server for journal events"
+config BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE
+       bool "enable journal remote tools"
+       select BR2_PACKAGE_LIBCURL
        select BR2_PACKAGE_LIBMICROHTTPD
        help
-         systemd-journal-gatewayd serves journal events over the
-         network. Clients must connect using HTTP. The server
-         listens on port 19531 by default.
+         journal remote functionality adds three tools:
 
-         http://www.freedesktop.org/software/systemd/man/systemd-journal-gatewayd.service.html
+         systemd-journal-gatewayd serves journal events over the
+         network.
 
-config BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE
-       bool "enable systemd-journal-remote"
-       depends on BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY
-       select BR2_PACKAGE_LIBCURL
-       help
          systemd-journal-remote is a command to receive serialized
-         journal events and store them to journal files. Input
-         streams are in the Journal Export Format[1], i.e. like the
-         output from journalctl --output=export. For transport over
-         the network, this serialized stream is usually carried over
-         an HTTPS connection.
+         journal events and store them to journal files.
+
+         systemd-journal-upload will upload journal entries to the
+         URL specified with --url=.
 
+         https://www.freedesktop.org/software/systemd/man/systemd-journal-gatewayd.service.html
          https://www.freedesktop.org/software/systemd/man/systemd-journal-remote.service.html
+         https://www.freedesktop.org/software/systemd/man/systemd-journal-upload.html
 
 config BR2_PACKAGE_SYSTEMD_BACKLIGHT
        bool "enable backlight support"
index b684f538a8c3553cebc795b5d2743929ccb0e296..6f04283bdccc51ba527bbe6028d9dc9efece058f 100644 (file)
@@ -240,18 +240,13 @@ else
 SYSTEMD_CONF_OPTS += -Danalyze=false
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)
-SYSTEMD_DEPENDENCIES += libmicrohttpd
-SYSTEMD_CONF_OPTS += -Dmicrohttpd=true
-else
-SYSTEMD_CONF_OPTS += -Dmicrohttpd=false
-endif
-
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE),y)
-SYSTEMD_CONF_OPTS += -Dremote=true
+# remote also depends on libcurl, this is already added above.
+SYSTEMD_DEPENDENCIES += libmicrohttpd
+SYSTEMD_CONF_OPTS += -Dremote=true -Dmicrohttpd=true
 SYSTEMD_REMOTE_USER = systemd-journal-remote -1 systemd-journal-remote -1 * - - - systemd Journal Remote
 else
-SYSTEMD_CONF_OPTS += -Dremote=false
+SYSTEMD_CONF_OPTS += -Dremote=false -Dmicrohttpd=false
 endif
 
 ifeq ($(BR2_PACKAGE_LIBQRENCODE),y)