boot/uboot: add support for having host-python-pyelftools as a dependency
authorShyam Saini <shyam.saini@amarulasolutions.com>
Thu, 18 Apr 2019 13:23:31 +0000 (18:53 +0530)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Apr 2019 20:21:37 +0000 (22:21 +0200)
Rockchip rk3399 SOC based boards require python pyelftools library for
parsing dtb files, so lets add it as uboot dependency.

This commit introduces a new config option
BR2_TARGET_UBOOT_NEEDS_PYELFTOOLS to achieve this.

Signed-off-by: Shyam Saini <shyam.saini@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index d4a93615eeb9904770e12be881d4bbf268cda084..33b7e67ff763fbaa8597edeeeca32107e7b593ad 100644 (file)
@@ -151,6 +151,14 @@ config BR2_TARGET_UBOOT_NEEDS_PYLIBFDT
          Select this option if your U-Boot board configuration
          requires the Python libfdt library to be available.
 
+config BR2_TARGET_UBOOT_NEEDS_PYELFTOOLS
+       bool "U-Boot needs pyelftools"
+       help
+         Select this option if your U-Boot board configuration
+         requires the Python pyelftools library to be available.
+         This is used by some rockchip SOCs for elf parsing.
+         For example: rk3399 soc boards.
+
 config BR2_TARGET_UBOOT_NEEDS_OPENSSL
        bool "U-Boot needs OpenSSL"
        help
index 3c070b41b3b0df4687b588ffede32d220cb3d866..ae09c37d84cbd69281ad1a7fe7ab01e351ac8dd5 100644 (file)
@@ -152,6 +152,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)
 UBOOT_DEPENDENCIES += host-python host-swig
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYELFTOOLS),y)
+UBOOT_DEPENDENCIES += host-python-pyelftools
+endif
+
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSSL),y)
 UBOOT_DEPENDENCIES += host-openssl
 endif