package/tini: compile executable static
authorSimon Rowe <simon.rowe@citrix.com>
Tue, 3 Dec 2019 13:59:47 +0000 (13:59 +0000)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Dec 2019 22:03:25 +0000 (23:03 +0100)
One usecase for tini is as the init process for a container which has
a single executable and no C runtime library. It therefore needs to be
independent of any C runtime library within the container.

Previously, we didn't build statically to avoid problems with
BR2_SHARED_LIBS=y. However, it turns out that tini can successfully link
statically even with glibc and BR2_SHARED_LIBS=y, because libc.a is
still included in staging, and tini doesn't use any NSS functionality.

Signed-off-by: Simon Rowe <simon.rowe@citrix.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/tini/tini.mk

index 5dd98777f96c3d0901a999dc577c4a5bdac25dc0..986e612a83a67041df316afe2465ac703ff442ac 100644 (file)
@@ -10,6 +10,7 @@ TINI_LICENSE = MIT
 TINI_LICENSE_FILES = LICENSE
 
 TINI_CFLAGS = $(TARGET_CFLAGS) \
+       -static \
        -DTINI_VERSION=\"$(TINI_VERSION)\" \
        -DTINI_GIT=\"\"